LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   RH Install via FTP (https://www.linuxquestions.org/questions/linux-software-2/rh-install-via-ftp-58742/)

bigslim 05-08-2003 12:08 PM

RH Install via FTP
 
I am having trouble installing Redhat on my laptop again...I was successful in the past with the FTP install and did have the RH 8/WinME dual boot cooking. I have since upgraded the harddrive and would like to install RH on the fresh partition. I am getting stuck at the FTP setup-I am pretty sure that my IP info is right, but I am getting an error message that will say "error logging into ftp site" and then another box will pop up saying "unable to retrieve disk image" I have tried different ftp sites with the same result. I have found that if the IP info is entered wrong-I get the other error that says" #$%^&(*&^%# is not a valid hostname" But if I put in my correct IP info-I get as far as entering the directory and then I will get the error that I cant log into the ftp site. Unfortunately I did not document my last install-I just has the bootnet.img disk left over-otherwise I dont remember how I did it last time..

Any Ideas? Maybe I am missing something simple-and just being a bonehead?

manthram 05-08-2003 02:05 PM

during install check the kernel logs in the virtual terminal. it will give you the specific details of the failure.

why dont you try 'hd' install. network install even with a broadband connection is very slow relatively

bigslim 05-08-2003 07:36 PM

I had this problem before-fortunately I wrote down the IP addresses and subnet mask and all of that. But for some reason I am getting this error that says I cant log into the ftp server. I am guessing that something needs tweaking as far as my ether connections go. What gets me is that I can access internet on the windows partition. I wish I had not upgraded the hardrive now-I had a good thing going with the dual-boot. As far as HD install goes-I would still have to DL the iso's for RH-9- Last time I did FTP install it took about 3 1/2 hours to DL-I have RH 7.2 on discs-however cd install is out of the question because of the PCMCIA cd-rom. How do I stop the scrolling so I can see the error specifics? Otherwise the screen jumps before I can get a chance to see the log.

bigslim 05-08-2003 09:13 PM

Here is the exact error message I am getting--->


-Error-

Failed to log into ftp.redhat.com
Failed to connect to FTP server


=OK=


Then when I click "ok" the next box pops up....

{FTP}

Unable to retreive the first install image

=OK=


*I have also tried other ftp sites-redhat is just an example

born4linux 05-08-2003 10:00 PM

get the ISOs - download them in your windows partition. check this link for a faster download:

http://www.linux-sxs.org/internet_br...ittorrent.html

bigslim 05-08-2003 11:44 PM

I would do that, except I dont have alot of room in the windows partition for the iso's-I have about 2 gigs altogether-and I have Win XP already on there . The rest of the hard drive is free space awaiting a fresh install of redhat...
The last time I did the FTP install-I never saw that error message-but the last time I did the install it was for RH8-And I noticed that there isn't a "bootnet.img" file for RH 9...I will keep cracking at it...

born4linux 05-09-2003 05:08 AM

network install option is also provided by the bootdisk.img. there is no bootnet.img in RHL 9. the bootdisk.img will prompt u what method to use.

try this site:

ftp://ftp.heanet.ie/mirrors/ftp.redh...x/9/en/os/i386

maybe u can bring ur PC to a friend's house, do a network setup there and then do the ftp install?

bigslim 05-09-2003 01:05 PM

I bet thats what it is-I had read somewhere else that I needed the "drvnet.img" for a network install, but when I tried to rawrite that to a floppy it didnt do anything but wipe out the data-and then it would prompt me to format the disk when I would access it because it was not formatted. I will try the "bootdisk.img" and see how that pans out..I will let you know.. I used that ftp site last time I did the network install-it has a good response time.

bigslim 05-10-2003 02:08 AM

Well that bootdisk worked -it got me into the ftp site. Now I am stuck in the setup right after it asks me for a root password-the next screen says "reading package information" It will do this for about 2 minutes, the I get an error that reads as follows:
=error=
Unable to read header list. This may be due to a
missing file or bad media. Press <return> to try again.

I have tried a few different ftp sites-and I still get that error message. Any suggestions?

born4linux 05-10-2003 05:25 AM

not sure what is causing that...i don't know - maybe the mods can help here? anyone?

the ones i've downloaded there are working fine (via rpm -ivh ftp://.....).

bigslim 05-11-2003 04:15 PM

Thank You for your help-I was able to complete the install via FTP-I used that "ftp. heanet.ie" site that you had mentioned earlier. I didn't go with RH9 as originally planned because of the problems I was having. I never did figure out why I couldn't get past the "reading packages" error-I dont want to rack my brain on that right now- I will look into that some other time..But I was successful with the RH8 install- I appreciate your input & assistance with this.

Thank You-


All times are GMT -5. The time now is 08:19 PM.