-   Linux - Software (
-   -   Reverting back to nouveau from bumblebee/nvidia fails (

Serophis 10-02-2012 11:03 AM

Reverting back to nouveau from bumblebee/nvidia fails

After the latest kernel update, bumblebee and/or the nvidia drivers fail. I decided to simply revert back to nouveau drivers but that doesn't work. I believe I have deleted everything relevant: dkms, bbswitch, bumblebee, nvidia drivers, xorg files (I might have deleted too much here, lol)... I don't know what else to try.

I have a Fedora 17 x86_64 system installed on an Asus N55SF laptop.

Here's the output of

rpm -qa *\nvidia\*  *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
lspci |grep VGA



nouveau                    886587  0
mxm_wmi                  12823  1  nouveau
wmi                            18697  3  mxm_wmi,nouveau,asus_wmi
video                          18936  2  i915,nouveau
i2c_algo_bit                13257  2  i915,nouveau
drm_kms_helper          40253  2  i915,nouveau
ttm                            79760  1  nouveau
drm                          259168  4  ttm,i915,drm_kms_helper,nouveau
i2c_core                      38177  7  drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,nouveau, videodev
cat: /etc/X11/xorg.conf: No such file or directory
user@address# lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 1247 (rev a1)

Any ideas? Anything else I should provide (logs, outputs, etc)?

I'll post Xorg.0.log as well:
Well, I have no idea how to copy files from one HDD to another, so that log is out. I can however type the result of "startx" and "systemctl status prefdm.service":

root@Obviously ~# startx
xauth: file /root/.serverauth.1119 (the number changes I think) does not exist

X.Org X Server 1.12.3
Release Date: 2012-07-09
X Protocol Version 11, Revision 0
Build Operating System: (tell me if this is needed. Nouveau isn't mentioned here)
Build Date: 20 September 2012 07:51:23AM
Build ID: xorg-x11-server 1.12.3-2.fc17
Current version of pixman: 0.24.4
        (irrelevant info)
Markers: (irrelevant)
(==) Log file: "/var/log/Xorg. (irrelevant)
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xinit: Unable to run program "xterm": No such file or directory
Specify a program on the command line or make sure that /usr/bin
is in your path

xinit: connection to X server lost

waiting for X server to shut down Server terminated successfully (0). Closing log file.

root@Obviously ~# systemctl status prefdm.service
prefdm.service - Display Manager
          Loaded: loaded (/usr/lib/systemd/system/prefdm.service; static)
          Active: inactive (dead) (Result: exit-code) since Tue, 02 Oct 2012 20:04:23 +0200
        Process: 926 ExecStart=/etc/X11/prefdm -nodaemon (code=exited, status=203/EXEC)
          CGroup: name=systemd:/system/prefdm.service

GlennsPref 10-03-2012 08:57 PM

Hi, you will need those xorg packages you removed.

The modules list shows the nouveau driver is loaded.
So it looks like it's a matter of getting x to load.

After you re-install xorg and possible dkms (depending on the nvidia video package)

I think dkms is required for all but the Proprietory nVidia .run package.

dkms=dynamic kernel module service.

Hope this helps, Glenn

Serophis 10-04-2012 08:43 AM

Thank you for the response.

I have reinstalled bumblebee, bbswitch and dkms as I had it (from this guide). And following your suggestion I did a:

yum reinstall xorg-x11*
Now the error I get when trying "startx" is "No screens found". Nouveau might have been blacklisted when I reinstalled xorg (I'll check that now), but it does seem to load.

Nouveau is not blacklisted anywhere now. The problem still persists.

Serophis 10-05-2012 12:12 PM

I've rebuilt xorg like so:

yum remove xorg-x11*

yum install @base-x
... and proceeded to un-blacklist nouveau after i installed akmod-nvidia.

"startx" gives me "No screens found", but in the beginning it says something about /.serverauth.(random number) "does not exist". Not sure how relevant.

Google is no help whatsoever.

Ok, I'm getting desperate and I don't want to program in Java on Windows... So here is the contents of Xorg.0.log typed by hand:

[    347.097]
X.Org X Server 1.12.3
Release Date: 2012-07-09
[    347.099] X Protocol Version 11, Revision 0
[    347.100] Build Operating System:    2.6.32-220.17.1.e16.x86_64
[    347.101] Current Operating System: Linux Obviously 3.5.4-2.fc17.x86_64 #1 SMP time and date whatever
[    347.101] Kernel Command Lince: Nouevau isn't blacklisted here
[    347.103] Build Date: whatever
[    347.104] Build ID: xorg-x11-server 1.12.3-2.fc17
[    347.105] Current version of pixman: 0.24.4
[    347.107]    Before reporting bla bla bla
[    347.114] (==) Log file: "/var/log/Xorg.0.log"
[    347.114] (==) Using config file: "/etc/X11/xorg.conf"
[    347.114] (==) Using config directory "/usr/share/X11/xorg.conf.d"
[    347.114] (==) No Layout section. Using the first Screen section.
[    347.114] (==) No screen section available. Using defaults.
[    347.114] (**) |-->Screen "Default Screen Section" (0)
[    347.114] (**) |    |-->Monitor "<default monitor>"
[    347.114] (==) No device specified for screen "Default Screen Section"
        Using the first device section listed.
[    347.114] (**) |    |-->Device "Videocard0"
[    347.114] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    347.114] (==) Automatically adding devices
[    347.114] (==) Automatically enabling devices
[    347.114] (==) FontPath set to:
[    347.114] (**) ModulePath set to "/usr/lib64/xorg/modules/extensions/nvidia,/usr/lib64/xorg/modules"
[    347.114] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    347.114] (II) Loader magic: 0x7c6ac0
[    347.114] (II) Module ABI versions:
[    347.114]    X.Org ANSI C Emulation: 0.4
[    347.114]    X.Org Video Driver: 12.0
[    347.114]    X.Org XInput driver : 16.0
[    347.114]    X.Org Server Extension : 6.0
[    347.115] (--) PCI:*(0:0:2:0) 8086:0116:1043:2050 rev 9, (I was unable to discern the rest from the picture I took. Let me know if this section is important)
[    347.115] (II) LoadModule: "extnod"
[    347.117] (II) Loading /usr/lib64/xorg/modules/extensions/
[    347.117] (II) Module extnod: vendor="X.Org Foundation"
[    347.117]    compiled for 1.12.3, module version = 1.0.0
[    347.117]    Module class: X.Org Server Extension
[    347.117] (II) Loading extension SELinux
[    347.117] (II) Loading extension MIT-SCREEN-SAVER
[    347.117] (II) Loading extension XFree06-VidModeExtension
[    347.117] (II) Loading extension XFree06-DGA
[    347.117] (II) Loading extension DPMS
[    347.117] (II) Loading extension XVideo
[    347.117] (II) Loading extension XVideo-MotionCompensation
[    347.117] (II) Loading extension X-Resource
[    347.117] (II) LoadModule: "dbe"
[    347.118] (II) Loading /usr/lib64/xorg/modules/extensions/
[    347.118] (II) Module dbe: vendor="X.Org Foundation"
[    347.118]    compiled for 1.12.3, module version = 1.0.0
[    347.118]    Module class: X.Org Server Extension
[    347.118]    ABI class: X.Org Server Extension
[    347.118] (II) Loading extension DOUBLE.BUFFER
[    347.118] (II) LoadModule: "glx"
[    347.118] (II) Loading /usr/lib64/xorg/modules/extensions/
[    347.118] (II) Module glx: vendor="X.Org Foundation"
[    347.118]    compiled for 1.12.3, module version = 1.0.0
[    347.118]    ABI class: X.Org Server Extension, version 6.0
[    347.118] (==) AIGLX enabled
[    347.118] (II) Loading extension GLX
[    347.118] (II) LoadModule: "record"
[    347.118] (II) Loading /usr/lib64/xorg/modules/extensions/
[    347.118] (II) Module record: vendor="X.Org Foundation"
[    347.118]    compiled for 1.12.3, module version = 1.13.0
[    347.118]    Module class: X.Org Server Extension
[    347.118]    ABI class: X.Org Server Extension, version 6.0
[    347.118] (II) Loading extension RECORD
[    347.118] (II) LoadModule: "dri"
[    347.118] (II) Loading /usr/lib64/xorg/modules/extensions/
[    347.118] blablabla not writing this **** again
[    347.118] (II) Loading extension XFree86-DRI
[    347.118] (II) LoadModule: "dri2"
[    347.118] (II) Loading /usr/lib64/xorg/modules/extensions/
[    347.118] blablabla vendor X.Org Foundation etc
[    347.118] (II) Loading extension DRI2
[    347.118] (II) LoadModule: "nvidia"
[    347.118] (II) Loading /usr/lib64/xorg/modules/drivers/
[    347.119] (II) Module nvidia: vendor="NVIDIA Corporation"
[    347.119]    compiled for 4.0.2, module version = 1.0.0
[    347.119]    Module class: X.Org Video Driver
[    347.666] (II) NVIDIA dlloader X Driver 304.37 time and date
[    347.667] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    347.667] (--) using VT number 4

[    347.685] (EE) No devices detected.
[    347.685]
Fatal server error:
[    347.685] no screens found
[    347.685]
Please consult the Fedora Project support bla bla bla the end

Phew! Please tell me this was worth it!

GlennsPref 10-05-2012 07:27 PM

Please check you have the X11-server installed tooo,

this was worth it!
So... you have the nouveau module/driver installed, but your x script is trying to initiate the nVidia module.

Could be as simple as editing the /etc/X11/xorg.conf file.

to get a console to login, try these key combination/s

Generally F1 through to F6 gives a login screen.
One maybe the failed x-server, just leave it for now and login as root to edit the xorg.conf file.

the xserver also looks after mouse and keys, when it's really broken you won't be able to type....


vi /etc/X11/xorg.conf
type "i" to insert(edit)

scroll down and replace nvidia with nouveau or add a line like this.

Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 6100 and later"
  # Driver "nv"    # this line is commented (#) and will not be read.
    Driver "nouveau"
  # Driver "nvidia"
  # Driver "vesa"

    Option "DPMS"

Next time you only have to swap hashes(#) to try a different module.
once you're happy with the edit,

type ESC, to exit insert mode.

type :wq! to write and quit vi. !=do it now!(force, you may not need !)

type exit to logout, switch back to the failed-gui (ctrl+alt+Fn)

type ctrl+alt+<-- (backspace) to restart the server (bit like win95, sometimes more is better, I use the sequence twice)

If no joy there reboot the pc.

Regards Glenn

GlennsPref 10-05-2012 07:43 PM


cat Xorg.0.log | grep EE
cat Xorg.0.log | grep nvidia
cat Xorg.0.log | grep nv
cat Xorg.0.log | grep .....

The (II) NVIDIA dlloader X Driver 304.37, is a beta , for stability revert to the 295.75 version.
if you go that way later.

when gathering info, on a cli you can redirect the output (to a file).

dmesg | grep nvidia > /home/glenn/build/dmesg-nvidia.txt
[    7.001971] nvidia: module license 'NVIDIA' taints kernel.
glenn@GamesBox:~                                                             (06-10 10:38)

the file "/home/glenn/build/dmesg-nvidia.txt" is created and saved.

>> (concatenate) will "add the output to a file that exists"


Serophis 10-06-2012 05:40 AM

Thanks for the help so far!

After editing /etc/X11/xorg.conf to say nouveau instead of nvidia, I also did a "yum install xorg-x11-server*" and installed everything there. With "cat Xorg.0.log | grep EE/nvidia" I noticed that module /usr/lib64/xorg/modules/extensions/nvidia was still being loaded. For that i did a cp of /etc/X11/xorg.conf.d/00-nvidia.conf to 00-nvidia.conf.old and deleted that file. Now only nouveau is loaded, but the problem still persists. No devices/no screens are found and .serverauth(random number) still doesn't exist.

"Started Display Manager" always fails when booting up. I'll come back with the contents of "systemctl status prefdm.service":

Loaded: loaded (/usr/lib/systemd/system/prefdm.service; static)
Active: inactive (dead) (Result: exit-code) since Sat, 06 Oct 2012 14:42:02 +0200
Process: 984 ExecStart=/etc/X11/prefdm -nodaemon (code=exited, status=203/EXEC)
CGroup: name=systemd:/system/prefdm.service
Maybe bumblebee might be ruining things here? Should I try to remove bumblebee and bbswitch together with the nvidia drivers perhaps? I can live with nouveau.

GlennsPref 10-07-2012 02:07 AM

OK, you'll need to,use an x-conf manager to change and test the screens. (it's prolly 1 instead of 0.)

At a command prompt type

Xorg -configure
X's own configurator.

from here...


bumblebee and bbswitch
I don't know what they are, so maybe not.

Serophis 10-07-2012 05:19 AM

I tried the Xorg -configure thingy but got an error that "Number of screens don't match number of devices" or something along those lines, and the xorg.conf file had a lot more information on it than it previously had.

HOWEVER, I might be on the verge of a breakthrough. I made a live usb image of Fedora and copied the contents of X11 there over to my computers X11 (I made a backup of the old X11 directory obviously). Now the screen on boot goes back between black and loading (with the mouse cursor) which shows great promise. The problem now, I think, is that the X11 folder I copied and pasted is configured for the usb on /dev/sdd/. Is there a way to change it?

cascade9 10-07-2012 05:27 AM

Optimus is a real PITA, and you may _never_ be able to use nouveau with the nVidia GPU in systems with optimus.

Serophis 10-07-2012 05:33 AM

The problem first appeared with the kernel 3.5.4-2.fc17-x86_64 with my bumblebee/bbswitch setup. I know that nouveau works on my system. Also, Display Manager starts now but flickers (probably due to some settings in the newly cped X11 directory), which shows real promise.

GlennsPref 10-07-2012 06:12 PM

I don't remember any usb or HDD details in xorg.conf.

But there may be something in /etc/X11/xorg.conf.d (a folder containing bits to load at boot)

fstab is where you generally find hdd mounting info.

That said, checkout /etc/X11/xinit/ to see if the usb-hdd is listed/loaded from a file there.

Try the X config editor again, check and test the screen size and resolution, change it to force a change, then revert back.

Don't neglect the vesa driver.

And have you tried the kernel cli at boot?

like, "nokmsboot" I usually use this in the oposite, To stop nouveau and allow nvidia to load.

Your agp settings may conflict with x-settings.

Try, adding xconfig=nouveau at the (grub boot) line press F2-4 to edit...

Serophis 10-10-2012 10:41 AM

Thanks for the help but I simply copy and pasted my home folder and reinstalled (amazed at how much is intact afterwards, lol).

I would have loved to play more around with this actually but I use and need this computer fully functional for school. At least now I know that I shouldn't try and use optimus technology without being prepared.

All times are GMT -5. The time now is 02:33 AM.