-   Linux - Software (
-   -   Resolved: VMWare - how to change screen resolution CentOS or Fedora guest (

taylorkh 11-09-2008 09:26 AM

Resolved: VMWare - how to change screen resolution CentOS or Fedora guest
I just built a CentOS 5.2 VM using VMWare Workstation running on Ubuntu 7.10. I installed VMWare tools from the Workstation menu. However, I was stuck with 640x480 or 800x600 screen resolutions. I then built a Fedora 9 VM. It shows me higher resolutions however, it will not run at more than 800x600.

This has not been an issue with Ubuntu, Kubuntu or various Windows VMs I have built. After some researching I came across a post on the VMWare community. It asked 2 questions:

Did you install VMWare Tools? (yes I did)
Did you CONFIGURE VMWare Tools? (well, no I did not)

I ran the configuration script as root using the following command

and I now can change the video resolution in my CentOS and Fedora VMs.

I ran the script on my Ubuntu 8.10 VM and while it did not need to make any changes to enable changing the video resolution (which already worked) it did offer to build several other modules to improve performance.

Bottom line - when building a Linux VM in VMWare - do not forget to configure the VMWare tools after installing them !!!


isonicq 12-16-2008 09:45 PM

I am running Red Hat Linux 5 Enterprise with a GNOME 2.14 desktop on VMWare 6.0.2. I have the same problem of not being able to change my screen resolution to anything greater than 800x600.

I tried installing VMWare tools, but somehow it doesn't work. This is how I tried to install it: Start up the Virtual machine, log into Linux Red Hat 5 as root, then release my cursor, and click VM > Install VMWare tools from the VMWare menu. When I do this, I get the notice

"Installing VMWare Tools package wll greatly enhance graphics and mouse performance in your virtual machine. WARNING: You cannot install VMWare tools package until the guest operating system is running. If your guest operating system is not running, ... install the VMWare Tools package later."

I then click the "Install" button.

Then nothing happens. The VM > Install VMWare tools option has changed to "Cancel VMWare tools install" but I see no installation wizard or prompts, even after waiting over an hour. When I try to run /usr/bin/, the file is not found.

Any idea what I can do to resolve this?
Thanks in advance :)

taylorkh 12-17-2008 08:54 AM

That is strange. What should happen is that an icon for a CDROM should appear on the guest desktop. It is titled VMWare tools. It opens in nautilus and shows the tools package as an rpm and a tarball. I believe the correct version for VMWare 6.0 is VMwareTools-6.0.2-59824.i386.rpm. You should be able to download the rpm from the VMWare web site and install it manually.

taylorkh 12-17-2008 09:06 AM

That said... try logging in to the guest as a non-root user. Then try installing VMWare tools. I did this and was prompted to supply the root password when I installed the rpm.

isonicq 12-18-2008 03:08 AM

Thanks for the help. My version of Linux didn't inform me that a new CD was inserted, so I wasn't aware that VMWare tools installed via the CD drive. Once that was sorted out, I just clicked the CDROM drive manually and it worked. Logging in as root wasn't the problem.

Chenchu 11-14-2009 10:42 AM

Thanks alot for posting this. I've looked for a solution for that too.
I couldn't get out of this 800x600 mode, now running smoothly on a higher resu.

I'm running CentOS 5.2 on VMware, I installed the tools from the vmware on the MS system (thru the vmware program), then I realized that i've to install it on the linux box too, so I did that.

but I couldn't find where is the file I need to config.
I've configed the way you said, and it works perfect now.

All times are GMT -5. The time now is 07:53 AM.