Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 01-03-2008, 08:26 PM   #1
LQ Newbie
Registered: Aug 2004
Posts: 19

Rep: Reputation: 0
Resolution Problem: login screen 1680x1050 gnome 1024x768 on fc6

well the subject basically says it all. I just got a hanns-g hi221 22" widescreen for xmas. I can get 1024x768 within gnome, but I want the native 1680x1050. Here are the things I've tried

1. using graphical menu>system>admin>display to change
2. using graphical menu>system tools>nvidia xorg settings
3. manually editing xorg.conf to add the 1680x1050
4. making 1680x1050 the only mode entry in xorg.conf
5. uninstalling nvidia drivers that I had installed with the nvidia package (1.0-9755) and installing from livna (kmod-nvidia 100.14.19- This required uninstalling my i565 kernel and getting the i686 due to a weird bug in anaconda that everyone else knows about but I just discovered.
6. repeating the attempt with the nvidia xorg settings tool.
7. banging head repeatedly against the wall

edit: video card is geforce 6200 turbocache

gdm starts up and brings up the standard login screen in 1680x1050. I put in the password and the desktop loads up in 1024x768. the graphical tools mentioned claim that the changes will be made when x is restarted, but they revert to 1024x768 after I restart X.

Lastly, in the Xorg log in /var/log/Xorg.0.log there is a line that says

(II) NVIDIA(0): Setting mode "1680x1050+0+0"
then there's a bunch of stuff about keyboard blah blah blah. a few warnings about font renderers being registered at priority 0 already. I assume that this all ends when the gdm login appears. Then, there is a final line

(II) NVIDIA(0): Setting mode "1024x768"

So apparently the driver thinks that it should be resetting the mode. there are no error messages before or after. But I can't find anything in the xorg.conf file that would make it think this. any ideas?

xorg.conf follows

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:30:30 PDT 2007

# Xorg configuration created by livna-config-display

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
    ModulePath      "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath      "/usr/lib/xorg/modules"
    FontPath        "unix/:7100"

Section "Module"
    Load           "extmod"
    Load           "glx"
    Load           "dbe"
    Load           "extmod"

Section "ServerFlags"
    Option         "Xinerama" "0"
    Option         "AIGLX" "on"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "microsoftmult"

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
 ### Comment all HorizSync and VertSync values to use DDC:
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HSD Hanns.G Hi221"
    HorizSync       24.0 - 94.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6200 TurboCache(TM)"
    Option         "AddARGBGLXVisuals" "True"

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1680x1050 +0+0"
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "Composite" "Enable"
thanks in advance.


Last edited by jungle; 01-03-2008 at 08:30 PM.
Old 01-04-2008, 02:59 PM   #2
Registered: Nov 2007
Posts: 41

Rep: Reputation: 15
### Comment all HorizSync and VertSync values to use DDC:
Old 01-04-2008, 04:14 PM   #3
LQ Newbie
Registered: Aug 2004
Posts: 19

Original Poster
Rep: Reputation: 0
I'm not sure what you mean. I commented out the lines, but it had no effect. However, I have partially solved the problem. If I click "apply" in the nvidia-settings app, I can get the desired resolution. However, when I restart X, it reverts to 1024x768, and I have to use the nvidia-settings again to get the desired resolution. I had not tried hitting apply previously, going straight for the xorg.conf update. This update appears not to work for some reason. Any tips on making the change permenant are still welcome
Old 01-04-2008, 10:24 PM   #4
Registered: Nov 2007
Posts: 41

Rep: Reputation: 15
The nvidia-settings tool won't save the changes unless you grant permissions on /etc/X11/xorg.conf (or run as root).
Old 07-11-2009, 06:08 AM   #5
LQ Newbie
Registered: Jul 2009
Posts: 1

Rep: Reputation: 0
it is not simply a permissions issue

I have the exact same problem (except that I want 1360 width). I've got 1360 width in my xorg.conf. I get 1360 width on the login screen but then it reverts to 1024 after login. "1024" is not in my xorg.conf. Just like "jungle" I can keep using the Nvidia app on each boot to configure back to 1360 but I'd rather just save it!

It isn't a permissions issue as this console trace shows:

david@david-desktop:/etc/X11$ ls -l
total 68
drwxrwxrwx 2 root root 4096 2009-04-20 15:08 app-defaults
drwxrwxrwx 2 root root 4096 2009-04-20 15:08 cursors
-rw-rw-rw- 1 root root   14 2009-04-20 15:07 default-display-manager
drwxrwxrwx 6 root root 4096 2009-04-20 15:04 fonts
lrwxrwxrwx 1 root root   13 2009-07-08 23:19 X -> /usr/bin/Xorg
drwxrwxrwx 3 root root 4096 2009-04-20 15:08 xinit
drwxrwxrwx 2 root root 4096 2009-04-20 14:59 xkb
-rw-rw-rw- 1 root root 2474 2009-07-11 11:43 xorg2.conf
-rw-rw-rw- 1 root root 2474 2009-07-11 11:43 xorg.conf
-rw-rw-rw- 1 root root 2564 2009-07-10 13:22 xorg.conf_
-rw-rw-rw- 1 root root 2546 2009-07-11 10:07 xorg.conf.backup
-rw-rw-rw- 1 root root 1037 2009-07-09 07:24 xorg.conf.backup_
drwxrwxrwx 2 root root 4096 2009-04-20 15:00 Xresources
-rwxrwxrwx 1 root root 3730 2008-06-25 03:05 Xsession
drwxrwxrwx 2 root root 4096 2009-07-09 06:47 Xsession.d
-rw-rw-rw- 1 root root  265 2008-06-25 03:05 Xsession.options
-rw-rw-rw- 1 root root   13 2007-07-24 10:59 XvMCConfig
-rw-rw-rw- 1 root root  614 2009-04-20 15:00 Xwrapper.config
david@david-desktop:/etc/X11$ grep 1360 xorg.conf
    Option         "metamodes" "CRT: 1360x768 +0+0"
david@david-desktop:/etc/X11$ grep 1024 xorg.conf
david@david-desktop:/etc/X11$ tail /var/log/Xorg.0.log
(**) 2.4G USB RF KeyBoard: (accel) keeping acceleration scheme 1
(**) 2.4G USB RF KeyBoard: (accel) filter chain progression: 2.00
(**) 2.4G USB RF KeyBoard: (accel) filter stage 0: 20.00 ms
(**) 2.4G USB RF KeyBoard: (accel) set acceleration profile 0
(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources
(II) NVIDIA(1): Setting mode "DFP:nvidia-auto-select+0+0"
(II) NVIDIA(0): Setting mode "1024x768"
(II) Entity 0 shares no resources
(II) Entity 1 shares no resources
david@david-desktop:/etc/X11$ uname -a
Linux david-desktop 2.6.28-13-generic #45-Ubuntu SMP Tue Jun 30 19:49:51 UTC 2009 i686 GNU/Linux
Old 07-11-2009, 11:30 AM   #6
LQ Newbie
Registered: Aug 2004
Posts: 19

Original Poster
Rep: Reputation: 0
I'm not sure it's a good idea to have xorg.conf world writable. It might break something. try running the nvidia-settings as root from terminal. Then apply and save to xorg.conf. It seems to me that xorg.conf is getting more and more outdated. That's a little annoying. It seems that a lot of gui apps bypass it or something. I may be wrong. Anyway doing what I said worked for me.

Last edited by jungle; 07-11-2009 at 11:31 AM.
Old 02-01-2010, 02:15 PM   #7
LQ Newbie
Registered: Feb 2010
Posts: 2

Rep: Reputation: 0
Cool SOLVED: gnome-settings-daemon changes the video mode

After adding some debugging and getting down to the issue, the problem startup script was gnome-settings-daemon.

Because I have an nvidia video card, every time I went to change my resolution, it would ask me if I want to use nvidia-settings instead. I would of course say "Yes" .. however, by selecting "No" I was presented with the option of choosing the default video mode, which I then changed to the one I want, instead of it's crazy default.

Old 02-01-2010, 02:18 PM   #8
LQ Newbie
Registered: Feb 2010
Posts: 2

Rep: Reputation: 0
And for the record, you can also use "xrandr -output $default -mode $mode" to set the video mode that you want - you don't need to do it manually with nvidia-settings.


gdm, mode, video

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
can't get screen resolution to 1024x768 marta Debian 18 03-26-2010 04:33 PM
Login Screen Resolution - FC6 marv_e56s Fedora 4 01-24-2007 10:55 AM
custom screen resolution (1680x1050@60Hz) whysyn Fedora 7 09-08-2006 11:02 AM
1680x1050 screen resolution under sarge lixy Linux - Laptop and Netbook 3 04-26-2006 01:00 AM
1680x1050 screen resolution with ubuntu? bert.baeck Linux - Laptop and Netbook 1 04-21-2006 01:54 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:28 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration