LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   resolution changes in KDE won't work (https://www.linuxquestions.org/questions/linux-software-2/resolution-changes-in-kde-wont-work-102619/)

shanenin 10-10-2003 07:53 PM

resolution changes in KDE won't work
 
I just installed Slackware two days ago, it was surprisenly easy. Finnally got X and KDE working today. I cannot get KDE to use any other resolutions then 1280 x 1024. I change it in the contol center, it tells me changes have been saved, and will work next time I log in. It does not change them. I am going crazy squinting. What can I do?

ilikejam 10-10-2003 08:36 PM

Hi.

look at /etc/X11/XF86Config.

There will be a section that looks like this:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480" "320x240"
EndSubSection
EndSection

The 'Modes' line lists all the resolutions available. put the resolution you want as the largest in the list.

e.g. If I wanted to run my X server at 800 x 600, I would have to delete the "1024x768" part in the above part. - The x server always tries to run at the highest resolution in the list.

Hope that helps.

Dave

shanenin 10-10-2003 08:46 PM

here is the last part of my XF86Config file
-----------------------------------------------------------------------
Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 1
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 4
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 8
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 15
Virtual 800 600
------------------------------------------------------------
I do not have anythign like that, do you think I could add that line?

pesho_p 10-10-2003 08:52 PM

Re: resolution changes in KDE won't work
 
Then modify your XF86Config by hand. Open (as root) it in your preferred text editor and put the desired resolution in front of the others. Below you can see part of my XF86Config file:
Code:

Section "Screen"
        Identifier "Display 1"
        Device    "MATROX CARD 1"
        Monitor    "Display 1"
        DefaultDepth    24
        DefaultFbBPP    32
        SubSection "Display"
                Depth    16
                Modes    "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth    24
                Modes    "1024x768" "800x600" "1280x960" "1600x1200"
        EndSubSection
EndSection

This will start X in 1024x768 (by default). For more information - http://www.xfree86.org/4.3.0/XF86Config.5.html:
Quote:

Modes "mode-name" ...

This entry is highly desirable for most drivers, and it specifies the list of video modes to use. Each mode-name specified must be in double quotes. They must correspond to those specified or referenced in the appropriate Monitor section (including implicitly referenced built-in VESA standard modes). The server will delete modes from this list which don't satisfy various requirements. The first valid mode in this list will be the default display mode for startup. The list of valid modes is converted internally into a circular list. It is possible to switch to the next mode with Ctrl+Alt+Keypad-Plus and to the previous mode with Ctrl+Alt+Keypad-Minus. When this entry is omitted, the largest valid mode referenced by the appropriate Monitor section will be used.

ilikejam 10-10-2003 08:59 PM

Hi again.

Could you post the whole of the XF86Config file, so that I can see what's going on a bit better?

Cheers.

Dave

pesho_p 10-10-2003 09:32 PM

Just to add to previous post: could you run 'XFree86 -configure' as root and post here /root/XF86Config.new (just this or as addition to your current XF86Config).
I'm also puzzled what is going on. What video/monitor do you have? Did you configure XF86Config by hand, or by xf86config, or...? Are you running RedHat 9 and Slackware {9,9.1} on a same hardware? Does it work as expected under RedHat? If so, then you can simply copy your XF86Config (or it is called XF86Config-4 under RedHat?) from RredHat to Slackware and it should work.

shanenin 10-10-2003 09:50 PM

here is my XF86Config file below. I have a newer verion of X11 in redhat(4.4), so Do you think I could still interchange them?
-------------------------------------------------------------------
Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "record"
Load "extmod"
Load "dbe"
Load "dri"
Load "glx"
Load "xtrap"
Load "type1"
Load "freetype"
Load "speedo"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" ""
Option "Device" "/dev/mouse"

Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
#DisplaySize 306 230 # mm
Identifier "Monitor0"
VendorName "HWP"
ModelName "v70s"
HorizSync 30-70
VertRefresh 50-120
Option "DPMS"
ModeLine "800x600/100Hz" 69.65 800 864 928 1088 600 604 610 640 -HSync -VSync

EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
Identifier "Card0"
Driver "i810"
VendorName "Generic"
BoardName "i810"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 1
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 4
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 8
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 15
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 16
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 24
Virtual 800 600
EndSubSection
EndSection


Section "ServerFlags"

EndSection

pesho_p 10-10-2003 10:19 PM

Replace this:
Code:

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 1
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 4
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 8
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 15
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 16
Virtual 800 600
EndSubSection
SubSection "Display"
Depth 24
Virtual 800 600
EndSubSection
EndSection

with this:
Code:

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

and try again (you can leave other options as well (1, 4, 8, and 15 bpp as well, but I don't see any reason). This way X will be started by default in "1024x768" mode (24bpp).

As for the XFree86 4.4.0: this thing doesn't exist (yet ;) you must wait 'till December for it - http://www.xfree86.org/#newrel).

shanenin 10-10-2003 10:19 PM

They both use version 4.3 , redhat uses 4.3-02

pesho_p 10-10-2003 10:52 PM

Quote:

Originally posted by shanenin
They both use version 4.3 , redhat uses 4.3-02
They both use XFree86 4.3.0, but on RedHat there is font server by default, mouse may point to something else than on Slackware, etc. Post here your config file from RedHat (in case it is not a problem).
Does it work with previous modification or you are afraid to try? :)

shanenin 10-10-2003 11:01 PM

I am going to give my wife some attension, the computer has gotten it all today. I am going to try this code you reccomended tomarrow
-----------------------------------------------------------
Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
--------------------------------------------

let you know how it works


All times are GMT -5. The time now is 05:17 AM.