-   Linux - Software (
-   -   remote application X11 forewording not working (

exodist 07-26-2004 07:00 PM

remote application X11 forewording not working
I have done this a lot, but on other systems, I configured the 2 I am currently using from the ground up in gentoo from a stage 1 install.

on the computer I wish the application to be displayed on I type:
xhost +
it says:
access control disabled, clients can connect from any host
I then type:
ssh (IP address of the host that will run the application)
I type:
export DISPLAY=""
I then try to run the application:

I get this error:
_X11TransSocketOpen: socket() failed for tcp
_X11TransSocketOpenCOTSClient: Unable to open socket for tcp
_X11TransOpen: transport open failed for tcp/

** CRITICAL **: Unable to open display

I have done this successfuly several times and am not sure why it is not working on my current configuration.

any ideas?

TBC Cosmo 07-26-2004 07:20 PM

Should it not be: ssh -X ?


-X      Enables X11 forwarding.  This can also be specified on a per-host
            basis in a configuration file.

Also, maybe -X is not necessary if enable x forward option in /etc/ssh/sshd_config is set to yes. Have not tried myself, but in my setup, the -X is not necessary.

exodist 07-26-2004 07:29 PM

same error (and I still had to use export command) like I said I have done it this way many many times, but it was on slackware.

kgodbey 07-26-2004 09:32 PM

Shouldn't you do the "xhost +" on the host running the application ( Since the app is running there, it would be using the X services on that machine, and the remote computer ( would be the one opening a client into the host's X server.

Probably wrong, probably stupid, but easy to try if you've got nothing else!

exodist 07-26-2004 09:42 PM

lol, I thaught it was clean, I used xhost + on the machine that was going to disoplay the program, and export on the machine that was runnign the program, that is also the correct way to do it, let me state once again, I manually typesd these commands to load xmms on these 2 machines for 3 months before changing them to gentoo, at which point the exact same commands in exact same sequence no longer worked, I am not lookinmg for command correction, I am looking for the problem, the syntax is correct and tested.

kgodbey 07-26-2004 10:33 PM

Sorry, didn't read carefully enough. Is there a default firewall setup? If one X has IPv6, do both have it (sounds like you configured both the same, though)? Does "strace xterm" give any more info?

exodist 07-26-2004 11:00 PM

strace isn't found, also I use eterm not xterm.

TBC Cosmo 07-28-2004 09:08 AM

Finally not too busy at work, so ....

On remote host:
sshd_config has X11Forwarding yes

on the local host:
ssh -X remotehost

And that worked fine

I did not do an "xhost +" on remote host
Both are Redhat AS2.1, remotehost is in runlevel 3 and only serving vnc displays. On those displays, "xhost" reports "access control enabled - only authorized hosts can connect"

Hope this gets you closer to a solution.

All times are GMT -5. The time now is 10:28 AM.