-   Linux - Software (
-   -   Relationship: sendmail <=> dovecot (

hfreeman 03-03-2005 01:58 AM

Relationship: sendmail <=> dovecot
I am running a RH FC2 system with sendmail as the smtp service, and dovecot for imap/pop3. In sending test emails on the local system I find that although I can send mail from command line as mail -s "test subject", and I can send same from Zimian, I cannot seem to receive mail in Zimian. All email is delivered to the "command line" mailbox. I am running sendmail as a nearly out-of-the-box default config, and dovecot with imap and pop3 but no ssl and using out-of-the-box authentication. Zimian hooks up and sends fine, but even if I send from me back to myself, I have to go to the command line mail client to read my mail.

I have made sure that sendmail and dovecot are running, and used netstat and nmap to make sure ports 25 and 110 are being handled. They are. I am able to telnet to these ports and I get the dovecot signature, so I know they are "live".

So, I find I do not really understand the relationships among sendmail, dovecot and Zimian. Setting aside Zimian for the moment, what parts of the mail send/receive job do each of sendmail and dovecot perform? Where are the interface points? What is going on here that I'm to inexperienced to recognize?

thanks in advance!

linuxxed 03-03-2005 07:35 AM

That mean your sendmail is configured properly but your POP3 is not!

To test POP3.

telnet localhost 110
user [your username]
pass [your password]

what do you see?

ALternatively use command line fetchmail and see if that works.

hfreeman 03-03-2005 09:38 PM

I tried telnet localhost 110 and I got nothing. Well, nothing intelligent. I did "get in", and I see

# telnet localhost 110
Connected to localhost.
Escape character is '^]'.

but that is all. I tried typing in user hankf and pass pwd and list, but got no output. I re-verified with # nmap -v localhost that 25 and 110 are being listened to, and they are.

The commanline fetchmail says "no mail for hankf" but if I type #mail I see two messages for that user.

Any more ideas on what I may have messed up?
Thanks again in advance!

linuxxed 03-04-2005 03:02 AM

you're saying you didn't get any welcome message from your POP3 using telnet?? That doesn't look good. As soon as you do a telnet - the server sends a welcome message like version etc etc. Did you get that?

Is your POP3 server looking at the correct mail directory? (/var/mail)

hfreeman 03-04-2005 11:41 AM

Okay, you got me to thinking, and that is always a good thing. I decided to get radical. I saved off my dovecot.conf and replaced it with a fresh copy of the example script, and started over, one step at a time. I had either tweaked something I should not have, or just messed up, but I had much better luck the second time around. Things seem to be working much better now, except I am having authentication issues from MS Outlook 2000 from "remote" users. Ximian, however, is now functioning, and local delivery seems to be up and running. I had to open port 110 on the firewall to let pop3 in, and now I must figure out what's up with the authentication from "foreign" clients,. Thanks for the assistance!

All times are GMT -5. The time now is 02:50 AM.