-   Linux - Software (
-   -   ReiserFS mount fails (

rpz 03-18-2005 09:48 PM

ReiserFS mount fails
I upgraded an older computer running RedHat 9 to Fedora Core 3. Everything went ok except for one of the four ReiserFS filesystems that will no longer mount. Instead, I get the following error message:

mount: Operation not supported
dmesg shows:

ReiserFS: hdd1: found reiserfs format "3.6" with standard journal
ReiserFS: hdd1: using ordered data mode
ReiserFS: hdd1: journal params: device hdd1, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hdd1: checking transaction log (hdd1)
ReiserFS: hdd1: Using r5 hash to sort names
ReiserFS: hdd1: warning: xattrs/ACLs enabled and couldn't find/create .reiserfs_priv. Failing mount.

reiserfsck didn't report anything unusual either so it's not like it got corrupted or anything. I really have no idea what went wrong. The other three reiserfs filesystems were created at about the same time and they show no problems at all. Also, if it's just some .file it can't create, shouldn't it be possible to just ignore that by passing -oignoremysteriousdotfiles (whatever :) ) to mount? I googled but the only thing I got was something about selinux (I'm not sure what that is except it's something NSA uses, and anyway I disabled it with selinux=0 but that didn't help).

Any suggestions?

julot 03-18-2005 09:58 PM

I would try removing the attribute
from the /etc/fstab file, in the line used for the problematic Reiser partition

rpz 03-18-2005 09:59 PM

I just found something rather weird: /sbin/hdparm reported that DMA on that drive was disabled! And that drive only -- all the other drives had DMA enabled (including the other HD on the same bus). (Enabling DMA speeds up reiserfsck from ~15 minutes to ~5 minutes, but does not solve my original problem.)
This might be related to the fact that I used bus 1 device 1 (slave device) with a DVD drive while copying over all the upgrade files. Maybe this affected something? This is really the only difference between that HD and the others (they are even the same size).

rpz 03-18-2005 10:02 PM


I would try removing the attribute
from the /etc/fstab file, in the line used for the problematic Reiser partition
There is no user_xattr in the fstab file. The line reads
/dev/hdd1 /local/disk4 reiserfs defaults 1 1

And defaults is according to the man page
Use default options: rw, suid, dev, exec, auto, nouser, and async.

I also tried -onouser_xattr, which was accepted by mount as a valid option, but it didn't do any difference.
I tried -onoacl,nouser_xattr too... didn't help

Update: I can mount read-only :D (forgot the easy solutions....). OK so now the files are safe, but can I easily recover the partition somehow without swapping ~60 GB of data?

xowl 03-18-2005 10:14 PM

Just a question:

The disk have LBA set in the bios??

All the other disks have??

rpz 03-18-2005 10:17 PM

About LBA I don't know. I think everything is just auto I guess. It's very hard for me to access bios setup as the system is remote and only accessable via ssh. I have not modified any bios settings and everything worked fine prior to the update.

rpz 03-19-2005 10:52 AM

By the way, how do I make hdparm settings persistant? It seems that on every reboot, the hdparm -d1 is forgotten. How do I save this setting (well, except the obvious rc.local) ?

All times are GMT -5. The time now is 03:31 PM.