-   Linux - Software (
-   -   ReiserFS 3.6 SegFault on mount attempt (

Gryphon 07-18-2006 06:45 AM

ReiserFS 3.6 SegFault on mount attempt
Hi all,

Knoppix Live CD 5.0 (the latest downloaded few minutes ago)
reiserfsprogs 3.6.19-2
kernel 2.6.17

have following problem:

disk with reiserfs get corrupted, partition table was lost. I have created new partition (working on "dd" image on the new disk) and run

fsck.reiserfs --rebuild-sb /dev/hdb4
fsck.reiserfs --check
fsck.reiserfs --rebuild-tree --scan-whole-partition /dev/hdb4

after that the partition seems to be OK (fsck.reiserfs --check shows no corruption) (and during semantic test I can see the filenames ....)

When I try to mount the partition I got following results:

mount /dev/hdb4 /rescue
You must specify filesystem type (or something like that)

mount /dev/hdb4 -t reiserfs /rescue
Segmantation Fault

(with following error in dmesg:
ReiserFS: hdb4: found reiserfs format "3.6" with standard journal
BUG: unable to handle kernel paging request at virtual address f8d6a004
printing eip:
*pde = 1ff18067
*pte = 00000000
Oops: 0002 [#1]
Modules linked in: efs ipv6 sworks_agp nvidia_agp efficeon_agp amd64_agp ali_agp af_packet reiserfs dm_mod agpgart fuse sg i2c_i801 tsdev parport_pc parport 8250_pnp 8250 aic79xx serial_core tg3 i2c_core shpchp e752x_edac edac_mc pci_hotplug evdev usbhid pcmcia firmware_class yenta_socket rsrc_nonstatic pcmcia_core video thermal processor fan container button battery ac unionfs cloop sbp2 ohci1394 ieee1394 usb_storage ohci_hcd uhci_hcd ehci_hcd usbcore
CPU: 0
EIP: 0060:[<f8e29ba9>] Not tainted VLI
EFLAGS: 00210202 (2.6.17 #4)
EIP is at reiserfs_fill_super+0x449/0xf68 [reiserfs]
eax: f7a7ccd0 ebx: 00002000 ecx: c016a3a8 edx: f75f3c38
esi: f8d6a000 edi: 00000400 ebp: f7aacc00 esp: f75f3c6c
ds: 007b es: 007b ss: 0068
Process mount (pid: 4440, threadinfo=f75f2000 task=f7efda90)
Stack: <0>c18f3040 00000403 00000000 00001000 f32126c0 00000094 00000001 c66d4000
f32126c0 00000000 c66d4000 00000003 00000000 00000003 00000000 00000000
00000000 00000000 00000000 00000000 00000004 00000004 00000000 00000020
Call Trace:
<c01f1dcb> vsnprintf+0x30b/0x534 <c01f2032> snprintf+0x1a/0x20
<c01a04a7> disk_name+0x5b/0x84 <c016f2b9> get_sb_bdev+0xc9/0x104
<f8e27b8e> get_super_block+0x1a/0x20 [reiserfs] <f8e29760> reiserfs_fill_super+0x0/0xf68 [reiserfs]
<c016e986> do_kern_mount+0x9a/0x144 <c018428d> do_mount+0x35d/0x6b4
<c01774f2> link_path_walk+0x66/0xd0 <c01577ae> __handle_mm_fault+0x52a/0x83c
<c0157464> __handle_mm_fault+0x1e0/0x83c <c01577e5> __handle_mm_fault+0x561/0x83c
<c01576ed> __handle_mm_fault+0x469/0x83c <c014f63c> get_page_from_freelist+0xb8/0x458
<c014fa29> __alloc_pages+0x4d/0x2d4 <c014ff00> __get_free_pages+0x28/0x3c
<c0183078> copy_mount_options+0x30/0x160 <c018465a> sys_mount+0x76/0xb4
<c010336b> syscall_call+0x7/0xb
Code: 31 ff 8b 85 c0 01 00 00 8d 1c fd 00 00 00 00 89 de 03 70 08 ff 75 0c 8b 44 24 20 01 f8 99 52 50 ff b5 b8 00 00 00 e8 23 33 34 c7 <89> 46 04 8b 85 c0 01 00 00 89 da 03 50 08 83 c4 10 8b 4a 04 85
EIP: [<f8e29ba9>] reiserfs_fill_super+0x449/0xf68 [reiserfs] SS:ESP 0068:f75f3c6c

another attempt causes the mount process to hang in D+ state

Any idea?

P.S. tried also on Sarge ... same results



chrisortiz 07-19-2006 06:04 PM

will it seg fault if you format as another partition type and mount it?

Gryphon 07-20-2006 07:51 AM

Problem is in reiserfsprogs?

thanx for the answer.

It seems there is a bug in the latest reiserfsprogs or it is incompatible with the filesystem on the disk

I tried to use older version of Knoppix (4) with reiserfsprogs-3.6.19-1 and it works now - no segfault, mount successfull

However the filesystem seems to be dead - I can see files, but except few all of them are full of thrash ... well, this is how the data can end ...

Thanx again


All times are GMT -5. The time now is 03:24 PM.