LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-15-2006, 06:14 AM   #1
mikeotieno
Member
 
Registered: Jun 2006
Location: Kenya
Distribution: SUSE OSS 10.1, Fedora 9 x86-64
Posts: 71

Rep: Reputation: 15
Question reinstalling lilo in master boot record


Am dual booting WinXp and Suse 10.0 OSS in a Toshiba laptop, my windows had a problem and i reinsatlled it in its location hda1 and Linux is in hda5. I boot the sustem with my suse cd 1 and entered rescue mode but when i try running command /sbin/lilo to rerun lilo again i get this error message;
Fatal: create /boot/map~: Read-only file system
please help. Thanx in advance.

Last edited by mikeotieno; 08-15-2006 at 06:16 AM.
 
Old 08-15-2006, 12:24 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,117

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Either lilo is trying to install itself on the CD ROM, or your /dev/hda is "read-only" (unlikely I think).
Try /sbin/lilo -b /dev/hda to tell lilo that you want it to install on the MBR of /dev/hda

If this doesn't work, boot from a live disk, mount your /dev/hda5 as /oldroot and then try

chroot /oldroot /sbin/lilo -b /dev/hda

Then shutdown and reboot

HTH

Last edited by tredegar; 08-15-2006 at 12:28 PM.
 
Old 08-15-2006, 12:28 PM   #3
tgo
Member
 
Registered: Dec 2004
Posts: 125

Rep: Reputation: 15
you can also from a live cd mount the partition, chroot it, then run lilo
 
Old 08-15-2006, 02:25 PM   #4
metalick
Member
 
Registered: Apr 2004
Location: Zagreb, Croatia
Distribution: SuSE 9.0
Posts: 44

Rep: Reputation: 15
Quote:
Originally Posted by mikeotieno
Am dual booting WinXp and Suse 10.0 OSS in a Toshiba laptop, my windows had a problem and i reinsatlled it in its location hda1 and Linux is in hda5. I boot the sustem with my suse cd 1 and entered rescue mode but when i try running command /sbin/lilo to rerun lilo again i get this error message;
Fatal: create /boot/map~: Read-only file system
please help. Thanx in advance.
hi. boot to your SuSE using the installation CD/DVD and use yast to reconfigure lilo
 
Old 08-16-2006, 09:38 AM   #5
mikeotieno
Member
 
Registered: Jun 2006
Location: Kenya
Distribution: SUSE OSS 10.1, Fedora 9 x86-64
Posts: 71

Original Poster
Rep: Reputation: 15
thanx guyz i figured it out using my suse cd, using the rescue mode which allowed me to reinsatll lilo. Thanx fot support
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Master Boot Record linuxuser05 Linux - General 3 01-11-2004 06:57 PM
LILO and currupted master boot record Bengal571 Linux - Newbie 2 08-13-2003 08:56 AM
master boot record alaios Linux - General 1 04-22-2003 08:41 AM
master boot record dark_light Linux - General 11 07-03-2002 05:21 AM
LILO in master boot record guerilla fighta Linux - General 1 02-10-2002 03:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration