LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   reinstalling lilo (https://www.linuxquestions.org/questions/linux-software-2/reinstalling-lilo-166563/)

deft 04-05-2004 04:39 PM

reinstalling lilo
 
Hi All,

I recently installed RH9 on a partition on my hardrive, the trouble is I also installed winodws 98 which now appears to have removed my lilo. I created a system disk:

fdformat /dev/fd0h1440
dd if=/boot/vmlinuz of=/dev/fd0

Which I think is right? ( is it right ) Does anyone know how i can get the lilo back ? is it possible to create the disk on another RH9 system. I know with other distro's that you reinstall the lilo from the cdrom, but it appears that RH have left out that handy utility.

Many thanks in advance...


deft.

LavaDevil94 04-05-2004 04:57 PM

i think redhat has a rescue capability on the 1st disk, which will reinstall lilo and from there allowing you to add a windows option.

deft 04-05-2004 05:33 PM

Any ideas how it works ? ? ? or how I access it

shanenin 04-05-2004 05:49 PM

I am probably missing something obvious. Does your rescue disk work? If it does, use that to boot, then you can rerun the command lilo
#/sbin/lilo

If you use the install cds It kind of walks you throught the procedure. I think you have to enter linux rescue(something like that) If you have knoppix you could use that very easily also.

deft 04-05-2004 05:53 PM

Thanks shanenin, I will give it a try..

deft

shanenin 04-05-2004 06:03 PM

one thought, did you reinstall windows 98, or did you change the partition table and install for the first time. If you repartitioned you may need to change you /etc/lilo.conf.

deft 04-07-2004 04:30 PM

Still got lilo trouble's
 
Hi All, ( again ) ( shanenin, Linux was already on the system I just reinstalled in the same partition and then installed windows which destryed my lilo... )

I am still having problems.... shanenin, I tried what you said about the rescue disk, and it was all going well until I tried to run the "/sbin/lilo" command. When you go into rescue mode the system mounts it into /mnt/sysimage. And when I cd into that directory my root filesystem is there, intact.

The problems start when I try to run /sbin/lilo, it doesn't work, I get a error saying that /etc/lilo.conf does not exist ? I have not got a clue what to do :scratch: When going to RH.com I find that there advice on the subject is: ( and I quote )

"When things go wrong, there are several ways to work on fixing them. However, they require that you understand the system well. We will present the ways that you can boot into rescue modes where you can use your own knowledge to rescue the system"

Thanks RedHat ( not ) Time for a change I think

Any help on this would make me a very happy ( and relieved ) Scotsman.....


deft...

shanenin 04-08-2004 09:52 AM

First I thought their was an automatic tool to fix you bootloader in the redhat installl cds(in rescue mode), I may be wrong about that. I am not exactly sure how the resuce mode works. If you specify where your lilo.conf is with the -C option it should work.
Code:

/sbin/lilo -C /mnt/sysimage/etc/lilo.conf
this should work assuming you can find your lilo.conf in the location /mnt/sysimage/etc/lilo.conf. Let me know if it works :)

deft 04-08-2004 10:03 AM

Thanks shanenin, am going to try it again tomorrow. I will let you know how I get on...



deft..


All times are GMT -5. The time now is 03:26 PM.