-   Linux - Software (
-   -   reinstalled apache, php, still no php support SuSE 8.2 (

hindenbergbaby 10-14-2003 08:56 AM

reinstalled apache, php, still no php support SuSE 8.2
I read the instructions till I'm blue in the face (I must just be dumb), alas... It seems as though apache is not recognizing that I have php installed. Here's what I did: I installed apache2.0.47 on my SuSE Linux with PHP 4.3.3 and mySQL. mySQL runs, apache runs, but I can't get phpMyAdmin to run or my browsers to recognize php other than stuff that's served to me from other web servers.

So I reinstalled Apache, this time (d'oh) with the ./configure -so command. It looks like it installed more modules and libraries than it did last time, but alas, still no php support. I think I am missing a php module... I configured httpd.conf to say AddType application/x-httpd-php4 but it doesn't seem to help. Any clues as to what I'm doing wrong?

Also, when I installed php, I did a very general, straight, install. ./configure, make, make install. Was there something else I should have done? Is there a way to fix it if there was? I was going on the instructions I had, which I'm beginning to fear weren't very good.

I tried to download the php module from SuSE, but it's for the wrong version of Apache, so it doesn't even recognize apache. Any help would be greatly appreciated.


david_ross 10-14-2003 01:42 PM

Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

I replied to your original thread yesterday. Do you have the LoadModule line?

The thread will continue here:

All times are GMT -5. The time now is 11:07 AM.