LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-15-2003, 03:58 PM   #1
jingo
LQ Newbie
 
Registered: May 2003
Distribution: Redhat 9.0
Posts: 2

Rep: Reputation: 0
redhat-config-packages error and hdparm


Hi all,
I am using redhat 8.0 and i have a few problems. First, the graphical package installer no longer works after i rebuilt the package database... it just starts and then dissapears... when i get the rollowin error when i run it from the terminal

unknown cddev scd0
rpmdb: /var/lib/rpm/Packages: unsupported hash version: 8
error: cannot open Packages index using db3 - Invalid argument (22)
Traceback (most recent call last):
File "/usr/share/redhat-config-packages/MainWindow.py", line 159, in ?
hdlist.mergeRpmDb()
File "/usr/share/redhat-config-packages/hdrlist.py", line 32, in mergeRpmDb
db = rpm.opendb(0, instPath)
rpm404.error

also using either xine, mplayer or ogle to play dvd's in kde (3.1) gives very choppy playback... i have been able to enable dma mode on my cdrw but not on the primary cd/dvd drive.. when i try to enable it using hdparm as root i get the following error...
/dev/cdrom:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
i know the drive is dma capable i just dont know why it doesn't work.. any ideas?

mintah
 
Old 06-15-2003, 05:00 PM   #2
bax
Member
 
Registered: Dec 2001
Location: NoVA
Distribution: Ubuntu, Solaris, OpenBSD
Posts: 492

Rep: Reputation: 30
You ever fix your Ogle problem?
 
Old 06-15-2003, 05:03 PM   #3
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
I think that rpm problem can be solved by deleting the existing rpm database:

rm -f /var/lib/rpm/__db*
rpm --rebuilddb

I found the redhat-config-packages application to be very buggy as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error In redhat-config-packages ! MHV134 Linux - Software 1 05-31-2004 11:14 AM
redhat-config-packages error (thinks it is redhat and not fedora) qwijibow Fedora 3 12-17-2003 09:59 PM
need help, error w/ redhat-config-packages ziggie216 Linux - Software 3 11-19-2003 07:53 PM
redhat-config-packages endezeichen Linux - Software 1 11-18-2003 08:56 PM
redhat-config-packages cmura Linux - General 1 03-26-2003 01:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration