LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-09-2004, 11:19 AM   #1
maciek
LQ Newbie
 
Registered: Mar 2003
Distribution: slackware
Posts: 24

Rep: Reputation: 15
recompiled kernel -> modules errors


ok here the thing, I recompiled the kernel 2.4.22 and works nice, however there's a little problem when I boot the system I get lots of messages abount modules that 'are not found'. And now's the catch these modules do exist in /lib/modules/, ok so I ran depmod reboot and again the same thing. It looks like that rc.hotplug is responsible for these errors is there a way to fix it? these error come up only when initialising usb, but eventually lsmod shows that they all are loaded and all the hardware works. If I disable the rc.hotplug script will I get the hotpluging abilities (like plug your camera and it's available)? cause it seems like it's kernel that invokes the hotplug program if there's new hardware am I right?
 
Old 01-09-2004, 11:29 AM   #2
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
If you do not want hotplug to load specific modules, you can add the to this list /etc/hotplug/blacklist . This is more to stop hotplug from loading modules that are already loaded, or do not need to be loaded.
 
Old 01-09-2004, 01:34 PM   #3
php
Member
 
Registered: Jun 2001
Location: USA
Distribution: Slackware
Posts: 827

Rep: Reputation: 30
If you don't actually _need_ hotplug there is really no reason to be using it at all. Most people don't need this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Recompiled and Installed Kernel 2.6.14.2 - No Modules Loading? timkarwoski Linux - General 18 11-21-2005 09:05 AM
Errors after recompiled Kernel longnam Slackware 1 05-03-2005 12:00 PM
recompiled kernel not in use taoweijia Linux - Newbie 1 01-09-2004 08:33 AM
recompiled kernel and no vmlinuz.old or kernel module for Nvidia Bruce Hill Slackware 13 12-11-2003 01:36 AM
Recompiled my kernel, don't know if modules are there... TheOneAndOnlySM Linux - Newbie 3 08-11-2003 12:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration