-   Linux - Software (
-   -   Recent mrxvt versions and backgrounds (

jayjwa 09-23-2006 09:48 PM

Recent mrxvt versions and backgrounds
I wanted to see if anyone else was having this issue before I considered it a bug. For awhile now, Mrxvt (xterminal, similar to rxvt, aterm and friends) has compiled with background support, but the actual backgrounds don't show up. Transparency is the same. The last working version I have is 0.4.2. I'm not talking about packages or RPM's, but the source as you'd get it here:

Currently, 0.4.2 I can recompile and it works as expected, but 0.5.1, no backgrounds, there is only solid black where there should be a pixmap. The image type doesn't matter.

X is XFree86 4.6.0, but I've attempted compiles with prior versions of mrxvt on implementations and had the same result.

A configure command like this should get a debug build with everything relavent enabled. You must set TERMENV in config.h to what you want as the script seems to set "rxvt" when I specify "mrxvt" (providing you do have an entry for an "mrxvt" in terminfo and termcap. You can also make one from the example in the source tarball if you have the "tic" program.)


env CFLAGS='-pipe -O2 -I/usr/local/include -I/usr/X11R6/include' CPPFLAGS='-pipe -O2 -I/usr/local/include -I/usr/X11R6/include ' LDFLAGS='-L/usr/X11R6/lib ' ./configure --prefix=/usr --enable-everything --enable-debug --enable-ourstrings --enable-mouseslipwheel --enable-text-shadow --enable-menubar --enable-transparency --enable-xrender --enable-xpm --enable-jpeg --enable-png --enable-xft --enable-xim --enable-utempter --enable-resources --with-termname=mrxvt --with-save-lines=600 --with-terminfo=/usr/share/terminfo --with-x
Running the resulting binary doesn't give much clue in the debug info.


[ jayjwa@vdrl:~/mrxvt-0.5.1>] src/mrxvt -pixmap /usr/share/pixmaps/winter.xpm

set default locale to en_US
argv[1] = -pixmap: Open X display :0.0
rxvt_get_xdefaults (mrxvt)
rxvt_get_xdefaults (Mrxvt)
rxvt_get_xdefaults (XTerm)
set multichar encoding to noenc
 load font (-misc-fixed-medium-r-normal--14-130-75-75-c-70-iso8859-1)
 load mfont (-misc-fixed-medium-r-normal--14-130-75-75-c-70-iso8859-1)
Got null root pixmap 0
Create scrollbar
mrxvt: Could not open file
Creating tabbar
allocate r->tabstop as 80
append_page (NULL, NULL)
last page is 0
Find vterm[0] for pointer vts[0]
Create VT 0 (17x24+560x336)
Unblanking pointer
argv = 0x0
rxvt_control_tty(): pid: 30428, tty fd: 5, dev: /dev/pts/1
rxvt_control_tty(): Voiding tty associations: previous=no
rxvt_control_tty(): /dev/tty has controlling tty? no (good)
rxvt_control_tty(): ioctl(..,TIOCSCTTY): 0
rxvt_control_tty(): do we have controlling tty now: yes (good)
rxvt_control_tty(): tcgetpgrp(): 30428  getpgrp(): 30428
rxvt_privileged_utmp 0 (s); waiting for: s (pid: 30427)
Adjust num_fds to 5
rxvt_scr_reset 0 ()
rxvt_scr_reset 0 () refresh screen
rxvt_scr_alloc 0 ()
rxvt_IM_get_IC() - successful connection
Geometry: 577x360+84+107
Size: Not resizing
reading from shell 0
read maximal 8191 bytes
read 46 bytes
no further data

bathory 09-25-2006 09:32 AM

Well, I have mrxvt 0.5.1 compiled from source, as per the INSTALL file:

./configure --enable-everything --disable-debug
and works fine, i.e. background and transparency work as expected.
Mind that there is a change in some of the keywords used in .mrxvt (and the respective options used from command line) when you run mrxvt. Read the man page for details.


jayjwa 09-25-2006 03:49 PM

Unfortunately I get the same results as far as backgrounds and transparenacy when using that minimal config. Time to pull out gdb and see what's going on I guess. :cry:

OK, started on this, everything looks good up until XMapWindow, here ->

XMapWindow (r->Xdisplay, PVTS(r, page)->vt);

Calling that renders the blacked out background I'm seeing.

Final Edit: Solved.

Enabling tinting is what was doing it.

--disable-tinting lets both transparent and pixmap options work (with everything else possible to enable enabled).

All times are GMT -5. The time now is 10:26 AM.