LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Received Grub Error 18 on boot up. (https://www.linuxquestions.org/questions/linux-software-2/received-grub-error-18-on-boot-up-626681/)

vinrod 03-08-2008 06:18 PM

Received Grub Error 18 on boot up.
 
Hello all:
I am a first time poster so please be gentle. I am also a Linux newbie with a healthy desire to learn.

A friend of mine gave me his son's hard drive and asked if I could recover data from it. He didn't know what OS was installed, just that it has a "glitch" of some sort. I plugged it into my first system and received the error that my board couldn't read the drive. Something about something being too long. I realized then that it was a 64bit install of a linux OS. Unknown distribution.

Then I plugged it into and AMD 64 X2 board and received a Grub error 18. After looking around, the majority of answers revolve around nuking the drive and starting over. Unfortunately, this is not an option as the drive is not mine and data is required to be removed from the drive and saved.

Is there a way of reinstalling grub so that the system will load the OS or will that jack the data and/or make the system unable to access the data? The data is very important to my friends son. Much thanks and I appreciate any help.

Larry Webb 03-08-2008 06:24 PM

Try this site, you are able to download a grub that you can put on cd and boot anything that is bootable. Also there are directions on the use.

http://www.gnu.org/software/grub/

JoeyAdams 03-08-2008 10:56 PM

This type of error usually occurs when the next stage of the boot process is too far out on the hard drive for the BIOS to access. The bootstrap CD mentioned above will probably not work unless you also include the Linux kernel from the system on the hard drive on the CD. Also, if the hard drive is bad, you can run a terminal utility called badblocks to search for bad partitions. These things can be set up by using a live CD (e.g. Kubuntu).

buckjams 03-13-2008 02:58 PM

Hi , Joey . I have a error 15 on a new 60gb HD. You mentioned using badblocks in the terminal.. I used sudo ls badblocks, it did'nt work.. What do you type in the terminal off a live cd?? I'm using a fiesty live cd to troubleshoot the hd problem..I did a gutsy install and there is a bad file on the cd I later found out.. I have been playing with Linux for over a year now and consider myself Green.. Any help would be great..I have tried wiping the drive and no go..This is a new HD... Thanks...
Buck....

vinrod 03-14-2008 12:44 AM

Found the fix
 
Hope this doesn't post twice. Thank you to everyone who made suggestions. During my research I found a site that provided the total fix. http://www.ultimatebootcd.com/ I would strongly suggest you check it out. Great stuff and free. Be well.

buckjams 03-14-2008 11:55 PM

Thank's for the info Vin... I will post the results when I have tried the CD..

Buck..

JoeyAdams 03-15-2008 10:45 PM

Quote:

I used sudo ls badblocks, it did'nt work
If I'm not mistaken, [K]Ubuntu Gutsy's live CD has badblocks installed by default (and most likely Feisty, too). When you say `sudo ls badblocks', you're listing the contents of the current directory. You can type `whereis badblocks' to locate it in standard Linux places. If `sudo badblocks' doesn't work, then you can type `sudo apt-get install badblocks' to install it.

Note that badblocks has three notable modes:

1. Non-destructive read-only (tests reads on all parts of the hard drive; safe and fastest)
2. Non-destructive write-read (writes test data to disk, reads it back, and places original data back; slowest and slightly dangerous)
3. Destructive write-read (fills the hard drive with garbage while testing it; slow, but faster than 2).

You'll also want to pass the -s flag so you'll get a progress bar. Type `man badblocks' for more information.


All times are GMT -5. The time now is 07:36 AM.