LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-17-2009, 05:56 PM   #1
MQMan
Member
 
Registered: Jan 2004
Location: Los Angeles
Distribution: Slack64 14.1
Posts: 576

Rep: Reputation: 38
Really Bad Rendering of Screen in TightVNC


I'm using TightVNC to connect to my Slack64 box, which is running vbatt's KDE 4.3.1. Prior to that, I was running the "stock" KDE that comes with 13.0, which also had the same issues.

Here's a screen shot of what it looks like, showing the desktop, from TightVNC.

I don't think I need to describe how bad it is, you can see for yourself. Note also, I don't even get the application names, showing in the menu.

I used the "High Speed Network" radio button when launching TightVNC.

What can I do, to improve the display I have.

Cheers.
 
Old 10-17-2009, 11:38 PM   #2
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,443

Rep: Reputation: 73
what command did you use to run the server? What color depth and geometry did you use?
 
Old 10-18-2009, 01:14 AM   #3
MQMan
Member
 
Registered: Jan 2004
Location: Los Angeles
Distribution: Slack64 14.1
Posts: 576

Original Poster
Rep: Reputation: 38
Just a straight "vncserver :1".

Which is all I used to use, on Slack 12.2, with KDE 3.5. Except that was with RealVNC, not TightVNC, as neither was shipped with Slack.

Looking at the config file, for TightVNC, it says the default is 1024x768 at a depth of 24.

Cheers.
 
Old 10-18-2009, 03:20 AM   #4
jedi_sith_fears
Member
 
Registered: Jan 2008
Location: Kolkata
Distribution: Fedora 29 XFCE
Posts: 136
Blog Entries: 1

Rep: Reputation: 29
Thumbs up

It seems that TightVNC using 8-bit color depth to render. There should be an option to make it 32-bit or 24-bit. That will solve your problem.
 
Old 10-18-2009, 04:36 AM   #5
MQMan
Member
 
Registered: Jan 2004
Location: Los Angeles
Distribution: Slack64 14.1
Posts: 576

Original Poster
Rep: Reputation: 38
Well, I'm using the default set up, which has this in the config file:
Code:
## These settings are the default. Uncomment and edit to change.
#
# $geometry = "1024x768";
# $depth = 24;
# $desktopName = "X";
And here's what TightVNC reports.

Cheers.

Last edited by MQMan; 10-18-2009 at 05:06 AM.
 
Old 10-18-2009, 06:57 AM   #6
jedi_sith_fears
Member
 
Registered: Jan 2008
Location: Kolkata
Distribution: Fedora 29 XFCE
Posts: 136
Blog Entries: 1

Rep: Reputation: 29
hmm, everything seems alright. Except the bad output.
 
Old 10-18-2009, 01:36 PM   #7
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,443

Rep: Reputation: 73
try it with Xfce
 
Old 10-19-2009, 12:03 PM   #8
MQMan
Member
 
Registered: Jan 2004
Location: Los Angeles
Distribution: Slack64 14.1
Posts: 576

Original Poster
Rep: Reputation: 38
I tried on another box, and am getting the same results with KDE4.

Xfce seems to be OK, but switching over isn't the solution I'm looking for.

Cheers.
 
Old 10-19-2009, 01:27 PM   #9
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,443

Rep: Reputation: 73
Quote:
Originally Posted by MQMan View Post
Xfce seems to be OK, but switching over isn't the solution I'm looking for.

Cheers.
I figured that, but I just wanted us to determine if it was a KDE problem, or a system problem. Since we now know it is a KDE problem we can look into those settings.

Try playing with the KDE graphics settings. In particular, you should be aware of what effects are turned on, graphics properties, etc. What is your graphics card and driver? Perhaps it currently is a known issue with KDE4.
 
Old 10-19-2009, 02:13 PM   #10
MQMan
Member
 
Registered: Jan 2004
Location: Los Angeles
Distribution: Slack64 14.1
Posts: 576

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by shadowsnipes View Post
Try playing with the KDE graphics settings. In particular, you should be aware of what effects are turned on, graphics properties, etc.
Let me try when I get home, and can bring up a second system, so I can see what I'm actually doing.
Quote:
Originally Posted by shadowsnipes View Post
What is your graphics card and driver?
It's a nVidia, and I have the nVidia drivers installed. But I didn't think that TightVNC, or any of the VNC variations actually used that. I thought they had their own drivers. It would be easy enough to pull them out, and use the "stock" driver.
Quote:
Originally Posted by shadowsnipes View Post
Perhaps it currently is a known issue with KDE4.
In which case, I would have thought there would be more reports of this.

Cheers.
 
Old 10-20-2009, 12:47 AM   #11
MQMan
Member
 
Registered: Jan 2004
Location: Los Angeles
Distribution: Slack64 14.1
Posts: 576

Original Poster
Rep: Reputation: 38
Well, the Info Center seems to think it's the correct resolution and colour depth as well.

I also tried "fiddling" with all the controls I thought mike make a difference. Nope, no real change.

I wonder if it's with trying out Nomachine's NX again, although I prefer that the VNC's are more lightweight.

Cheers.

BTW I've also asked this thread be moved to the software forum, as I think that's probably a more appropriate place now.
 
Old 10-20-2009, 03:49 AM   #12
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
As requested, moved to Software
 
Old 10-20-2009, 04:21 PM   #13
MQMan
Member
 
Registered: Jan 2004
Location: Los Angeles
Distribution: Slack64 14.1
Posts: 576

Original Poster
Rep: Reputation: 38
OK, this is looking more and more like the way KDE is rendering the display.

I switched to NoMachine's NX server, to try that instead.

The display is much, much better, but there is still some dithering in places, as can be seen her.

Cheers.
 
Old 10-20-2009, 11:10 PM   #14
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,443

Rep: Reputation: 73
When you tested Xfce did you open any QT4 apps?

I noticed that when I start VirtualBox, anytime I have a QT4 app open the whole display turns to garbage - inverted colors and all. This is true in any Window Manager, and I have to restart the WM to fix it.

If there are no problems with qt4 apps in other WMs then it truly must be a problem with KDE.

Edit: The graphic issue with VB was fixed for me by disabling the Composite Extension

Last edited by shadowsnipes; 10-20-2009 at 11:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cinelerra: problem with colors (good in composition, bad after rendering) simopal6 Linux - Software 1 02-22-2008 12:23 PM
TightVNC blank screen with FreeBSD 7.0 beta em00guy *BSD 2 11-11-2007 08:47 AM
How to go back to a small screen on TightVNC jialan Linux - Software 1 07-08-2007 01:57 PM
ATi drivers indicates Direct Rendering, but bad libGL soundwave Fedora 26 11-23-2006 02:52 PM
Tightvnc: I can login but my screen is blue Meriadoc Linux - Newbie 3 06-14-2004 06:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration