-   Linux - Software (
-   -   Random freezes, don't know why (

randomshinichi 06-06-2005 03:31 AM

Random freezes, don't know why
On Gentoo Linux, I'm using 2.6.11-gentoo-r6 on a laptop with the following:
VIA C3 933MHz "C5C"
VIA PN266T/VT8233 (S3 ProSavage DDR graphics)
And the problem is, ever since I got Direct Rendering working on this computer, it started having random freezes. Like just now, it froze when a script ran ldconfig. This time it didn't freeze.
Let me take a moment to describe these freezes: They are instant, the display doesn't respond, picture just stays there, cursor doesn't blink. I press Caps, Scroll Lock. The lights DO NOT light up. Sometimes, when there was disk activity when the freeze happened, the hard disk light would remain on. Since the hard disk in my laptop is pretty much silent, I don't know if it's still accessing the disk or not.
Upon rebooting, everything is normal. Metalog, however, doesn't report anything. I don't have a /var/log/messages, everything goes to /var/log/everything.
My question is: How do I troubleshoot this kind of problem? How do I get to see an error message, at least, so I can tell you guys what's going on? Somebody?

Moloko 06-06-2005 04:00 AM

Direct Rendering is handled by the kernel, so I guess the problem lies there if the problem is linked to Opengl. Have you tried another (previous) version of the kernel?

Artanicus 06-06-2005 04:08 AM

me and several other nvidia users have been having this problem with various kernels. For us the common ground has been an nvidia graphics controller, and a nForce2 chipset on the motherboard.. No solution has been found, but the new glibc-solibs-2.3.5 for slackware boasts a fix for something like this (didnt fix it for me tho).. Heres a grab from the changelog, if its any help to you..


Mon May 16 15:27:24 PDT 2005
a/glibc-solibs-2.3.5-i486-2.tgz: Recompiled including a patch found
in Debian's glibc sources that fixes an issue with TLS that breaks
X and XMMS on machines that use nVidia's X drivers. This might
also be found in glibc CVS by now, but I'm not sure about that. In
any case, if you had problems before and you're using nVidia's
drivers, this should fix it. Also, I heard a few reports of trouble
with Firefox not working with NPTL -- maybe this will also fix that?

randomshinichi 06-07-2005 11:58 AM

Yeah, these random crashes have been happening since 2.6.10-gentoo-r2 (the oldest I tried, didn't try anything older). There's a temporary workaround I found, though. It appears that the drm modules, "drm" and "savage", appear to crash my computer only when they have been loaded. I modified it so that it doesn't load these modules during boot, and so far it has been stable under a 12 hour stress test (usually freezes within 8 hours or so).
When you start X, if you enabled DRI, it automatically loads those modules for you, so.... uh.... yeah. But be warned, it still crashes that way.
BTW: if I change my glibc to that (which is highly unlikely) do I have to recompile everything?

All times are GMT -5. The time now is 11:46 PM.