LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-17-2014, 01:28 PM   #1
TheChronicScribbler
Member
 
Registered: Nov 2013
Posts: 31

Rep: Reputation: Disabled
Unhappy Random Characters like "^[OR" popping up in the terminal, Disrupting typing.


Hello.

Wierd Problem.

Random characters popping up in terminal without me typing it.(like a string of "^[ OR"s)

When booting Fedora, string of "^[[ C " appearing. Then instead of the bar showing booting progress, the screen starts to blink with lots of info about the startup process.

When using apps like firefox, thunderbird, gedit etc, in between typing, the cursor goes straight into the "Find in page" bar, and then the app tries to iteratively find the string typed into it, making the screen go up and down.

Now, on rebooting, the characters, @ and " has exchanged places in the keyboard!!!!

Please help.
 
Old 07-17-2014, 04:14 PM   #2
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,982

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Is it a USB or PS/2 keyboard ?

Maybe the keyboard is failing, try a spare.
 
Old 07-18-2014, 12:10 AM   #3
TheChronicScribbler
Member
 
Registered: Nov 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Its on my laptop. Is there any way to disable the laptop keyboard and make Linux use the spare one as default for the time being?
 
Old 07-19-2014, 11:54 AM   #4
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,982

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
I would first try just plugging the USB keyboard in.

To disable any input device use xinput:
https://bbs.archlinux.org/viewtopic.php?pid=990273

You can also try the Fn keys on the laptop.
 
  


Reply

Tags
boot, display, terminal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
screen: Something keeps typing "AT+GCAP" to my terminal displace Linux - Software 2 02-26-2014 04:50 AM
[SOLVED] cant make a file executable by terminal typing "chmod +x layerfx.py" froylan Ubuntu 3 07-26-2012 02:41 PM
"random" xorg resets ... quickly typing in the GUI a "2" resets X Tinkster Slackware 3 04-09-2010 04:25 AM
typing "international characters" on Zenwalk tsuren Zenwalk 3 09-30-2006 03:56 PM
How to start KDE automaticlly without typing "startx" then "startkde" Jonescity Slackware 8 10-29-2004 09:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration