LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-26-2017, 04:56 PM   #1
Kgeil
Member
 
Registered: Mar 2014
Posts: 33

Rep: Reputation: Disabled
RANCID-Postfix aliases not working


Hi, I have gotten RANCID up and running using the directions here: https://help.ubuntu.com/community/RANCID. It sends the email to postfix, but when I look at mail.log, I see that it's not being sent to the address that corresponds with the RANCID group in /etc/aliases. All it does is append mydomain.com to the end of the rancid-group. My /etc/aliases file reads like this:

rancid-test kgeil@mydomain.com
rancid-admin-test kgeil@mydomain.com


And the log is here:

May 26 16:11:57 ubuntu postfix/smtp[29561]: 0BB8BE140E: to=<rancid-test@mydomain.com>, orig_to=<rancid-test>, relay=exchange-01.mydomain.local[10.101.0.100]:25, delay=0.24, delays=0.03/0.01/0.01/0.2, dsn=2.6.0, status=sent (250 2.6.0 <20170526201157.0BB8BE140E@ubuntu> [InternalId=717644] Queued mail for delivery)


From the directions on the help.ubuntu.com page, it appears as if rancid will send mail to postfix, addressed to the rancid-test group, and postfix will use the alias to address it to me, but it's not working that way, no matter how many configurations I've tried. If anyone has any advice, I'd be very grateful.
Thank you!

Kevin
 
Old 05-27-2017, 11:26 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,843

Rep: Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868
Quote:
From the directions on the help.ubuntu.com page, it appears as if rancid will send mail to postfix, addressed to the rancid-test group, and postfix will use the alias to address it to me, but it's not working that way, no matter how many configurations I've tried.
Did you remember to run
Code:
newaliases
afterwards?
 
Old 05-27-2017, 01:13 PM   #3
Kgeil
Member
 
Registered: Mar 2014
Posts: 33

Original Poster
Rep: Reputation: Disabled
I did, thank you. I still just get the same results.
 
Old 05-27-2017, 04:32 PM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,843

Rep: Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868
Quote:
Originally Posted by Kgeil View Post
I did, thank you. I still just get the same results.
Now I see that you miss the colon sign ( : ) after the name you want to alias
Code:
rancid-test: kgeil@mydomain.com
rancid-admin-test: kgeil@mydomain.com
 
Old 05-30-2017, 08:20 AM   #5
Kgeil
Member
 
Registered: Mar 2014
Posts: 33

Original Poster
Rep: Reputation: Disabled
Thanks again @Bathory, I did have colons in there, but missed them when typing into my original post. I've restarted everything, ran newaliases, but still get the same result. Is my assumption correct that postfix should take an email destined for rancid-test, and forward it to kgeil@mydomain.com if the /etc/aliases file is set up this way?

Thanks,
Kevin
 
Old 05-30-2017, 09:20 AM   #6
Kgeil
Member
 
Registered: Mar 2014
Posts: 33

Original Poster
Rep: Reputation: Disabled
Solved!

I just figured it out. I am using a relay to send mail through (my local exchange server). What I was missing is that /etc/ailases is only used for local delivery (though I thought this would do it). What I needed to do was to configure /etc/postfix/main.cf to contain:
Code:
virtual_alias_maps = hash:/etc/postfix/virtual

My answer was here:
https://serverfault.com/questions/74...ill-be-ignored

Thanks for looking!

Kevin
 
  


Reply

Tags
aliases, email, postfix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 6.5, Rancid 3.0, not working.... gdizzle Linux - Newbie 5 05-23-2014 02:09 AM
Aliases not working with Postfix Virtual Users Setup pankaj_garg Linux - Networking 1 02-26-2013 12:19 PM
Cisco RANCID - enable not working eliufoo Linux - Software 1 11-18-2012 10:26 AM
rancid not working kamran.ayub Linux - Server 0 01-17-2012 06:40 AM
Postfix aliases riotpunk Linux - Software 1 07-23-2004 03:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration