LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-21-2009, 01:04 PM   #1
White Sun
LQ Newbie
 
Registered: Apr 2009
Posts: 3

Rep: Reputation: 0
"r8169" Realtek problem Kismet


I wanted to say Hello(!) to everybody on the forum as i'm new here.

I also have a problem:
Im running Ubuntu 8.10 and im trying to configure Kismet and I've been fixing the configuring files with my user and network card info and capturing interface (r8169 ,wlan0 ,Ws) with the last being my user. But when i run Kismet ("sudo Kismet") i get the error :

Launching kismet_server: //usr/bin/kismet_server
Suid priv-dropping disabled. This may not be secure.
No specific sources given to be enabled, all will be enabled.
Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
Enabling channel hopping.
Enabling channel splitting.
FATAL: Unknown capture source type 'r8169 ' in source 'r8169 ,wlan0 ,Ws'
Done.

As Kismet does not recognize my capture source (r8169) so I have to download new driver or something?
My network card is called: "RTL8101E/RTL8102E PCI Express Fast Ethernet controller"

I appreciate any help i can get, Thank you.

Last edited by White Sun; 04-21-2009 at 01:05 PM.
 
Old 04-22-2009, 01:09 AM   #2
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 52
First, I think you need to post output of:
Code:
lspci | grep -i network
Since you have not given us info about your wireless device. For kismet, we use network controller, not ethernet controller.
 
Old 04-22-2009, 09:46 AM   #3
White Sun
LQ Newbie
 
Registered: Apr 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Oh sorry,
Well this is the output I get from "lspci | grep -i network":
04:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
 
Old 04-23-2009, 03:24 AM   #4
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 52
Ok. you need to edit your /etc/kismet.conf as follows:
Code:
suiduser=<your normal user, not root>
This suiduser setting might not work well in Ubuntu, just try.

You need to set source as follows:

Code:
source=iwlagn,wlan0,Intel
CMIIW.
 
Old 04-24-2009, 02:02 AM   #5
White Sun
LQ Newbie
 
Registered: Apr 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Hey, I get the same error when I change the code to "source= iwlagn, wlan0,Intel"
After I got the error I searched the internet for problems with iwlagn and it seems like some of them referred me to the driver iwl4965 instead, so i now tried to configure my file once again so it looks like: "source= iwl4965, wlan0, Intel".
When I then run "sudo kismet", It works!
Although... after playing around with it for a while (everything works perfectly, I get the packages sent and received and all that both from my own network and from my neighbours.

But then when i tried to access the internet, it dosen't work! I check my network status and it says im still connected to my wireless networik. I tried to close down kismet but it still wont work, and ive tried multiple internet programs all on different ports. I've also tried to restart my computer but to no use.

I guess i'll have to rewrite /etc/kismet.conf again so i dont get the right driver and then restart my computer but does anyone know why this happens?
 
Old 04-24-2009, 10:56 AM   #6
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 52
Kismet locks your wireless device in monitor mode (sometimes, it cannot revert it back for common use).

If you want to use wireless for other uses, you need to modprobe -r iwlagn / iwl4965 and then modprobe iwlagn / iwl4965 again. (You need to choose one, I don't know which one). This will reset your wireless to managed state.

Maybe you want to use two devices; one for monitoring, another for regular use.

CMIIW.
 
Old 07-03-2009, 11:34 AM   #7
h2osmack
LQ Newbie
 
Registered: Jul 2009
Posts: 1

Rep: Reputation: 0
Just letting you know I have a wifi 5100 intel using the iwlagn driver.
I went into the kismet.conf file and changed the source to:

source=iwl4965,wlan0,wifiKis #instead of iwlagn,wlan,wifiKis

It ran straight away, even though i'm a bit confused that I don't have that driver installed.
In order to reconnect the Internet after your done using Kismet (in Ubuntu 9.04 at least), make sure the program is properly stopped first.
Then right click your network manager and disable wireless. Then re-enable it and voila, it should reconnect to your access point.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"FATAL: Unknown capture source type" error from Kismet atlantanewbie Linux - Wireless Networking 2 04-03-2010 05:34 AM
Kismet won't compile with Imagemagick and "user is not root" mixtr Slackware 2 05-02-2006 04:40 PM
kismet "channel get ioctl failed...no such device" fatblueduck Linux - Software 0 01-03-2006 01:51 AM
Error: Make on kismet-2005-08-R1 "undefined reference" zeevolking Linux - Software 1 12-23-2005 08:40 PM
"make" gives error in kismet Pinkdog Linux - Software 2 11-03-2003 03:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration