-   Linux - Software (
-   -   Questions about Tor and Blossom (

Drivx 09-07-2007 10:22 AM

Questions about Tor and Blossom

This is my second post in this forum. Sorry if I have spelling or grammar errors, because I'm not English, but Spanish.

Well... I've some questions about the use of Blossom with the anonymizer software Tor.

I downloaded Blossom from here . Then, I unpacked the tarball. Later, I ejected the Tor program and Blossom (by Python interpreter). The torrc file is well configured to accept controller applications (I uncommented the #ControlPort 9051 line) and it's situated in the correct directory.

When I'm going to use both programs, first I start Tor client and I eject the file. Then I open my Firefox web browser and I write the address

I wait, and wait, and wait... but nothing appears. Firefox tries to connect, but as I said before, nothing appears.

Do somebody has the same problem? Do you know what could be happening?


unSpawn 09-08-2007 03:40 AM

Is TOR itself running? Does it's log show any errors? Can you connect through a local proxy (like Polipo or Privoxy) to TOR?

Drivx 09-09-2007 02:16 PM


The first time, when I tried to use Blossom, Tor already was in use. I tried use Tor with and without Privoxy.

But now (the second time after the compilation), when I've tried to eject Blossom, it shows this message:

drivx@aftereight:~/security/blossom$ ./
Traceback (most recent call last):
  File "./", line 3183, in <module>
  File "./", line 3144, in main
    conn = getConnection()
  File "./", line 1934, in getConnection
  File "/home/drivx/security/blossom/", line 169, in authenticate
    self._sendAndRecv("AUTHENTICATE %s\r\n"%hexstr)
  File "/home/drivx/security/blossom/", line 154, in _sendAndRecv
    lines = self._sendImpl(self._doSend, msg)
  File "/home/drivx/security/blossom/", line 376, in _sendImpl
    raise self._closedEx

What's happening?


unSpawn 09-10-2007 02:00 AM

So is TOR itself still running? Can you send control messages with the python script that came with TOR? Does the firewall block the port? Note you can't use TOR for most services without connecting through a local proxy like Polipo or Privoxy. The error itself doesn't make it clear to me if Blossom has trouble connecting or authenticating: best check that with the Blossom developers on their mailing list.

Drivx 09-10-2007 04:48 AM


I'm going to say what do I do since I switch on my computer. When I'm in the Desktop, I eject my Tor client in the terminal and it shows this:

drivx@aftereight: ~$ tor
Sep 10 10:42:17.171 [notice] Tor v0.1.2.17. This is experimental software. Do no
t rely on it for strong anonymity.
Sep 10 10:42:17.187 [notice] Initialized libevent version 1.3d using method epoll. Good.
Sep 10 10:42:17.187 [notice] Opening Socks listener on
Sep 10 10:42:17.343 [notice] Opening Control listener on
Sep 10 10:42:18.078 [notice] I learned some more directory information, but not
enough to build a circuit.
Sep 10 10:42:18.562 [notice] I learned some more directory information, but not
enough to build a circuit.
Sep 10 10:42:21.078 [notice] We now have enough directory information to build c
Sep 10 10:42:24.156 [notice] Tor has successfully opened a circuit. Looks like c
lient functionality is working.

I use Privoxy, but it charges automatically when I start my OS.

And then, I eject the file, which shows the above error message.

So, do I have to do anything else?


PS: How can I access to Blossom's mailing list?

unSpawn 09-11-2007 11:51 AM

Apparently there's no mailinglist and one person central to this all: Maybe try and contact him.

Drivx 09-13-2007 03:05 PM

OK, I'll try it.

I spoke by IRC with several Tor users, but the most of them don't usually use Blossom.

If I get the solve to my problem, I'll post the results.

Thank you.


unSpawn 09-13-2007 04:48 PM


Originally Posted by Drivx (Post 2890918)
If I get the solve to my problem, I'll post the results.

That would be awesome. Good luck!

archon810 10-09-2007 10:43 PM

I'm having the same exact problems. Have you found a solution?

Gary987 11-12-2007 08:52 PM

same here with those traceback issues.

All times are GMT -5. The time now is 09:55 PM.