LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-14-2005, 04:04 PM   #31
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15

update: Ok I FINALLY managed to get into var/www/html , the problem was the SELinux on fedora 4, i disabled it for the ftpd and now i can finally navigate in /var/www/html
However, i'm still getting a list error,

[R] USER webmaster
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R] EPRT
[R] EPSV
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] TVFS
[R] 211 End
[R] PWD
[R] 257 "/var/www/html"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PORT 192,168,1,101,11,120
[R] 500 Illegal PORT command.
[R] List Error
[R] PORT 192,168,1,101,11,121
[R] 500 Illegal PORT command.
[R] List Error

vsFtpd starts by itself, it is enabled in runlevel 5 and 3
 
Old 07-14-2005, 04:08 PM   #32
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Ah, forgot all about SELinux being on FC4 and how it can affect it.

What are you using to login with? Just straight ftp from a command line or a specific application like gftp or some other client?
 
Old 07-14-2005, 04:16 PM   #33
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15
actually im trying to login from a computer on the same network, im using FlashFXP on a windows XP machine and it doesnt work

But on my linux box when i type in command line ftp localhost followed by username and pass, it works fine, might it be just the ftp browser i'm using?
 
Old 07-14-2005, 04:19 PM   #34
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Quote:
Originally posted by LinuxStart
actually im trying to login from a computer on the same network, im using FlashFXP on a windows XP machine and it doesnt work

But on my linux box when i type in command line ftp localhost followed by username and pass, it works fine, might it be just the ftp browser i'm using?
Nah, sounds more like your firewall settings... passive mode will use more upper ports rather than just 20 and 21.. try disabling your firewall to test, then you can narrow it down and change your rules to allow the hosts you trust.
 
Old 07-14-2005, 04:26 PM   #35
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15
yes but i disabled passive mode, if i use passive mode i get:
[R] USER webmaster
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R] EPRT
[R] EPSV
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] TVFS
[R] 211 End
[R] CWD /var/www/html/
[R] 250 Directory successfully changed.
[R] PWD
[R] 257 "/var/www/html"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (192,168,1,103,154,101)
[R] Opening data connection IP: 69.158.66.67 PORT: 39525
[R] Data Socket Error: Connection refused
[R] List Error
[R] PASV
[R] 227 Entering Passive Mode (192,168,1,103,100,114)
[R] Opening data connection IP: 69.158.66.67 PORT: 25714
[R] Data Socket Error: Connection refused
[R] List Error
 
Old 07-14-2005, 04:28 PM   #36
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Keep passive mode disabled and make sure both ports 20 and 21 have access then. Notice the port numbers used when using passive mode, your getting connection refused which is a good sign your firewall is working..
 
Old 07-14-2005, 04:32 PM   #37
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15
heh, i left the firewall OFF and tried it with passive mode off and you are right, the firewall was blocking ports, i still get the list error tho
 
Old 07-14-2005, 05:53 PM   #38
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Quote:
Originally posted by LinuxStart
heh, i left the firewall OFF and tried it with passive mode off and you are right, the firewall was blocking ports, i still get the list error tho
List error? Is that after you do an ls or the system during login?
 
Old 07-14-2005, 05:58 PM   #39
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15
[R] USER webmaster
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R] EPRT
[R] EPSV
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] TVFS
[R] 211 End
[R] PWD
[R] 257 "/var/www/html"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PORT 192,168,1,101,12,254
[R] 500 Illegal PORT command.
[COLOR=red[R] List Error[/COLOR]
[R] PORT 192,168,1,101,12,255
[R] 500 Illegal PORT command.
[COLOR=red[R] List Error][/COLOR]

right there, everything else seems ok
is there any way to remove that sym link we used?

from another Ftp program i got this
STATUS:> Home directory: /var/www/html
STATUS:> This site supports features.
STATUS:> This site supports SIZE.
STATUS:> This site can resume broken downloads.
COMMAND:> REST 0
350 Restart position accepted (0).
COMMAND:> PORT 192,168,1,101,14,149
500 Illegal PORT command.
ERROR:> Syntax error, command unrecognized.
ERROR:> Failed to establish data socket.


The odd thing is that my friends can actually connect...

Last edited by LinuxStart; 07-14-2005 at 06:19 PM.
 
Old 07-14-2005, 07:15 PM   #40
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15
Update:

I just figured out anyone can connect to my server who is not on my network.

However, when i try to connect to my own server which is located on a lan with my other comuters i get the above error.

BUT
If i try to connect with 192.168.1.101 which is the local ip of the terminal i am at, it works fine. Ill do a little more fiddling to see where i can get to .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsFTPd Question carlosinfl Linux - Networking 3 10-31-2005 04:37 PM
vsFTPd question(s) username17 Linux - Software 5 05-19-2005 11:31 PM
vsftpd question bbmak Linux - Software 3 04-30-2005 10:03 PM
vsftpd question daveime Linux - Security 1 10-08-2004 07:12 AM
vsftpd question Drogo Linux - Software 6 01-29-2003 05:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration