LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-21-2003, 04:57 PM   #1
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Quake 3 error :/


Hi again!!!

I'm trying to install the very first Linux game in my life and I'm not doing very well . I'm getting this error message when I run Quake3 at the console:

Q3 1.11 linux-i386 Nov 24 1999
----- FS_Startup -----
Current search path:
/home/alex/.q3a/baseq3
./baseq3/pak0.pk3 (3539 files)
./baseq3

----------------------
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: Batcomputer
IP: 217.215.139.223
----- R_Init -----
...loading libGL.so: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
...loading libMesaVoodooGL.so: QGL_Init: Can't load libMesaVoodooGL.so from /etc/ld.so.conf or current dir: /usr/local/games/quake3/libMesaVoodooGL.so: cannot open shared object file: No such file or directory
failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Error: GLimp_Init() - could not load OpenGL subsystem


Does anyone knows what I'm missing out? I've mesa installed and I believe (not sure) that I've the latest nvidia drivers installed to my Geforce4 MX 440. I'm running Mandrake Linux 9.1 with default kernel. Any help would be great.

P.S: after this big error, my screen resolution gets odd, way too big and I've to reestart X :/....
 
Old 05-23-2003, 11:56 AM   #2
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
Re: Quake 3 error :/

Quote:
Originally posted by Megaman X
Does anyone knows what I'm missing out? I've mesa installed and I believe (not sure) that I've the latest nvidia drivers installed to my Geforce4 MX 440. I'm running Mandrake Linux 9.1 with default kernel. Any help would be great.

P.S: after this big error, my screen resolution gets odd, way too big and I've to reestart X :/....
The fact that you have Mesa and Nvidia installed at the same time can often lead to this problem. I had a similar situation happen when I installed Half-Life using Wine. I had to install the Mesa Libraries to get Wine to compile with OpenGL support, but installing Mesa overwrote some of the NVidia driver files. I would try reinstalling the Nvidia Drivers using their slick new autoinstall proggie, and then go into your XF86config file and make sure that GLX is enabled. Do a glxinfo and see what the results are. It should should that GLX is installed with the Nvidia driver, and not the Mesa Driver. Example:

$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer
client glx vendor string: NVIDIA Corporation
client glx version string: 1.2
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_SGIX_swap_group, GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce2 MX/AGP/SSE
OpenGL version string: 1.3.1 NVIDIA 31.23


Is similar to what you should expect to see. Run it and report back any error messages and we'll see if we can straighten it out.

slight
 
Old 05-23-2003, 12:40 PM   #3
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Original Poster
Rep: Reputation: 64
Thanks a lot for your reply slightcrazed. I've bookmarked this page and I will try as soon as I can. I've made something wrong and I cannot boot into Linux right now . I believe I've to install it over but I will try with RedHat 9.0 instead of Mandrake...

Thanks once again
 
Old 05-23-2003, 12:57 PM   #4
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
I also replied to your post regarding the Kernal Panic. It seems like a simple enough problem, so hopefully we can get it fixed.

slight
 
Old 05-24-2003, 08:28 AM   #5
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
Question: I have this exact same problem with an ATI Radeon 32 meg DDR card...would this be the same sort of solution? I haven't installed any drivers since Mandrake 9.1 and X 4.3.0 seem to have set it up correctly (ie: If I try Tux Racer it plays just awesome)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Quake IV bad error :( DarkNeo Linux - Games 19 11-24-2005 11:51 AM
Error from quake 3 DarkNeo Linux - Games 2 08-30-2005 09:32 AM
Quake 1 error bungle_42 Linux - Games 0 06-09-2004 07:12 AM
Quake 3 Error in Mandrake 9.1 Eve7698 Linux - Games 1 11-21-2003 05:04 PM
Quake 3 Bus Error Morf Linux - Software 0 09-05-2003 06:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration