LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   qmail "smtp service not running" (https://www.linuxquestions.org/questions/linux-software-2/qmail-smtp-service-not-running-475531/)

saini_mw 08-20-2006 12:56 AM

qmail "smtp service not running"
 
Hi dear all,

i have configured qmail server according to "Life With Qmail" when i process the command qmailctl stat it says that qmail-send and qmail-smtp services are running and the log services for both are also running but the time comes in front of smtp and send is (0)sec, now when i process the command netstat -a | grep smtp the command is processed but gives no output, also i am not able to telnet on my 25 port by using telnet x.x.x.x 25 command.

Before installing qmail i had removed all the sendmail packages..

is there any solutions to resolve this problem...???

Thanks in advance..

Regards,

Harinder Singh.

dambla 08-20-2006 02:58 AM

look at /var/qmail/control/rcpthosts (or where you installed qmail). if it isn't there you have to create it. also, you should have /var/qmail/supervise/qmail-smtpd/

saini_mw 08-21-2006 02:59 AM

i have both the things but still same problem..see the output of these commands:_


[root@inder ~]# cat /var/qmail/control/rcpthosts
server.inder.com
[root@inder ~]#


and

[root@inder ~]# ls /var/qmail/supervise/qmail-smtpd/
log run supervise
[root@inder ~]#


Regards.

Harinder Singh

dambla 08-21-2006 01:43 PM

do a qmailctl restart and read the log for qmail-smtpd and see if it gives any errors. maybe wrong permissions on executable files or something. the log should be in /var/log/qmail.


All times are GMT -5. The time now is 06:54 AM.