-   Linux - Software (
-   -   Qmail installation with CentOS (

waelaltaqi 11-10-2006 04:33 PM

Qmail installation with CentOS
i'm trying to follow instructions for installing Qmail on my CentOS box. everything was going fine until i reached this point:


[root@localhost ~]# patch</downloads/qmailrocks/patches/ucspi-tcp-0.88.errno.patch
can't find file to patch at input line 4
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
|diff -u ucspi-tcp-0.88.old/error.h ucspi-tcp-0.88/error.h
|--- ucspi-tcp-0.88.old/error.h 2000-03-18 09:18:20.000000000 -0600
|+++ ucspi-tcp-0.88/error.h    2003-01-08 13:39:12.000000000 -0600
File to patch:

what is the path for the file that i want to patch? i tried:


[root@localhost ~]# updatedb
[root@localhost ~]# locate ucspi*

but it coudn't find nothing. any ideas?

Lenard 11-11-2006 09:34 AM

The patch command is wrong try adding the switch -p0 or maybe -p1 to it, for example;

patch -p0 < the_rest

waelaltaqi 11-13-2006 02:40 PM

i tried that as well and it's coming back with the same output. i would like you to take a brief look at the page:

take a look at the first red box in the middle of the page, where it says: Patch needed for redhat users. this is where i'm stuck. I'm using CentOS 4.4 so i don't know if the patch is needed or not. is there anyway to check that?

Lenard 11-13-2006 03:20 PM

Ok, after looking at this again with greater attention. It seems that the command is incomplete. You need to get the file ucspi-tcp-0.88.errno.patch downloaded to patch one file. That patch file is here;

Just download the patch and apply in the usual way (patch -p0 or -p1) from the root of the qmail source directory. Or if you want simply follow the patch an manually make the edit, basically your just replacing one line in the ucspi-tcp-0.88/error.h file.

waelaltaqi 11-15-2006 07:29 AM

it was just a newbei mistake. i wasn't working from the same directory so the patch util wasn't able to find the patch file. thanks for your help. i'll try to pay more attension next time before asking.

All times are GMT -5. The time now is 08:11 PM.