-   Linux - Software (
-   -   qemu: qemu stopped right after command exec (

bitpicker 03-04-2005 05:51 AM

qemu: qemu stopped right after command exec
I have recently tried to boot a Knoppix CD with qemu - I've done it before, and it always worked. However, I seem to have made an error in the parameters then, and that time it failed. Now the problem is that since then, qemu only opens the emulator window with a blank, black screen, and in the window title there appears 'qemu stopped'. This only happens when I try to use it as the user who made the error, as root it works as usual, and with the same command. The stopped window does not react to attempts of starting the console (ctrl + 2) either, so I have no idea how to restart the emulation. There seems to be some kind of temp file or config file which prompts qemu to stop immediately, as this behaviour also survives a reboot, but I cannot find any in either the home directory or /tmp.

The command I am using is

qemu -cdrom /dev/cdrom -boot d -snapshot -m 256

It doesn't matter which bootable CD I put in the drive, the behaviour is always the same. Does anyone know how to change this setting or how to unfreeze qemu?


bigrigdriver 03-05-2005 12:25 AM

It sometimes happens, rarely, but sometimes, that an error condition can be preserved in a file which is essentially a temporary file. The file is preserved if the error causes the program to terminate abnormally, or if the program is closed improperly. Such files names usually end with ~ (tilde) or _ (underscore).
What I suggest is a tedious, time-consuming solution. But, it may solve your problem.
Use 'find' to search for filenames ending with ~ or _. Such as: find *.*~ or find *.*_. Redirect the output to a text file ( > find.txt) to study at your convenience. Depending on the size of your OS, it will take a long time.
Look for files ending with ~ or _, especially those relative to gemu and cdrom. You may have an error condition trapped in a temporary file which will plague you until you remove it.

To reduce the time required to find the offending file, use 'find' on the following directories: /etc, /home, /var, and /tmp. They are the most likely locations for such a file.

All times are GMT -5. The time now is 12:54 AM.