-   Linux - Software (
-   -   Qemu Emulation of Win32/MacOSX Support/Tutorial on Linux (

initialdrifteg6 12-08-2004 01:13 PM

Qemu Emulation of Win32/MacOSX Support/Tutorial on Linux
I'd like to dedicate this section for the qemu (pref. 0.6.1 or more current version) emulation.

I personally am looking to see about emulating Mac OSX v10.3 on my debian box. The first problem that i encountered was the inability to mount the CD1. I am using the origional Mac OSX CDs.

When the attempt to mount the CD i get an error sayin that it could not read the file system. Any Help or Comments is/are appriciated.

If you have any kind of information on emulation or qemu i'd like to urge people to post them here since it'll compile a nice list that could help many people.

sigsegv 12-08-2004 01:20 PM

The OSX CDs are not stardard iso9660 format. They're hfs IIRC. Stick a -t hfs in your mount command.

initialdrifteg6 12-08-2004 01:42 PM

Awesome.. i new that it was something in the mounting, but wasn't sure...

2nd part.... any one familiar with qemu and using it?

i've tried doin something like

qemu /dev/hdc <-- for the cdrom drive

and it started to boot the win2k cd that i had in there but the win2k setup couldn't find any harddrives!

initialdrifteg6 12-09-2004 02:02 AM

debian:/media/cdrom0# mount -t hfs /dev/hdc /media/cdrom0
mount: block device /dev/hdc is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems

now what? arg.. mounting the cd didn't work! =(

sigsegv 12-09-2004 07:04 AM

My bad. They're hfsplus. See this mailing list post.

initialdrifteg6 12-10-2004 08:54 AM

here's where i'm at now... still not much further, but better off than where i was...

i mounted the Mac OSX CD (disk 1) with

mount -t hfsplus /dev/hdc /media/cdrom0

and that worked... i can see the whole CD.

i made a hdd image (3GB) using

qemu-img create hdd.img 3G

My problem with it is that now when i use qemu, it doesn't like seeing the mac cd as bootable. do i have to tell qemu what processor i want it to emulate or somethin?

i don't have the qemu line in front of me, but it was something like

qemu -cdrom /dev/hdc -hda hdd.img -boot d

I would like to get this silly mac os on here.... heh... any more suggestions? =)

sigsegv 12-10-2004 11:27 AM

If you look at this page, you find this:


PowerMac Emulation
Operating System                State        Tested QEMU version        Comments
GNU/Linux Mandrake 9.1 PowerPC        -              0.6.0                  In progress (pb during X11 installer)
Darwin 7.01                        -              0.6.0                In progres (OF loader bug)
Mac OS X                        -              0.6.0                In progres (error during hw CDROM check)

Maybe try PearPC? I got pear running OSX on Win32 once. It wasn't bad at all, though it was *very* slow compared to a native PPC (Even my lowly 800 G4).

initialdrifteg6 12-10-2004 11:41 AM

Yea... i saw pearPC and was thinkin about that... i like qemu and got my win2k workin nicely.... i even have my usb workin on it... and my networkin.... heh... but i wanted to mess with osx.... i'll use anything to see if i can get it on here... hmm... .we'll see... thanks again...

zero79 12-12-2004 02:53 PM

u should do

qemu -cdrom /dev/cdrom -boot d hdd.img


initialdrifteg6 12-12-2004 03:10 PM

hey zero... jump on AIM... you're never on anymore!

initialdrifteg6 12-12-2004 03:29 PM

see... the problem with doin that is that the fact that the Mac OSX CD isn't bootable... i can't get it to boot.... i've gotten Win2k to boot off of the exact same script but with the macosx cd in... no luck... and why aren't you online yet?!?

initialdrifteg6 12-12-2004 03:37 PM

check out that picture... it's the product of running your command line above zero...

to mount the cd i did

mount -t hfsplus /dev/hdc /media/cdrom0

what the frapp is goin on yo?

mickyg 02-15-2005 01:32 PM

Ok, you may or may not be aware that mac have a different architecture to pc's, pc typically are refered to as x86, whereas macs are called power pc's (ppc for short), the reason qemu doesn't work with the command:

qemu -cdrom /dev/cdrom -boot d hdd.img

is because the qemu command emulates a x86 architecture, you need to emulate a ppc architecture.

luckily the writters of qemu have thought about all this architecture stuff and if you open a console window, type qemu and hit the tab key you should get something like this:

[mickyg@]$ qemu
qemu qemu-fast qemu-img qemu-sparc
qemu-arm qemu-i386 qemu-ppc qemu-system-ppc
[mickyg@]$ qemu

Each of these are different emulators. I'll give a very brief description:

qemu - emulates x86 architecture for windows, linux etc,
qemu-fast - same as qemu but fastest, and I think, slightly less stable but not sure on that one,
qemu-img - creates/edits/converts the .img file which qemu uses as the HD for the OS you want to emulate,
qemu-ppc - emulate a ppc environment for a program, i.e. like wine but for ppc programs (iTunes etc)
qemu-system-ppc - emulates a ppc architecture for MacOSX.

The others emulate various other architecture but I haven't used them so don't know much about them.

So, the command you actually want is:

qemu-system-ppc -cdrom /dev/cdrom -boot d hdd.img

(Note that since you refer to the cdrom as /dev/cdrom you don't actually have to mount it)

I've tried this and it boots MacOSX but tells me I need to restart everytime so I haven't got it working yet but that's the command you need to use.

If you get it working post how cause I desperately want to play with OSX!!!!

Hope this helps :)

All times are GMT -5. The time now is 08:24 AM.