LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-21-2014, 10:45 AM   #1
cov
Member
 
Registered: Apr 2005
Location: Durban
Posts: 436

Rep: Reputation: 30
Python3 installation fails:


I've posted this question on the Ubuntu forums without getting any help, so I'm reposting here to try to reach a wider audience. Hope that's ok.

My python installation seems to be borked. I tried to reinstall the update-manager as below:

Code:
dave@Threepwood:~$ sudo apt-get install update-manager
Reading package lists... Done
Building dependency tree 
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
update-manager : Depends: python3 but it is not going to be installed
Depends: python3:any (>= 3.3.2-2~)
Depends: update-manager-core (= 1:0.196.12) but it is not going to be installed
Depends: python3-dbus but it is not going to be installed
Depends: python3-gi (>= 3.8) but it is not going to be installed
Depends: ubuntu-release-upgrader-gtk but it is not going to be installed
Depends: update-notifier but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
dave@Threepwood:~$ sudo apt-get install python3
Reading package lists... Done
Building dependency tree 
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
python3 : Depends: python3.4 (>= 3.4.0-0~) but it is not going to be installed
Depends: python3-minimal (= 3.4.0-0ubuntu2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
dave@Threepwood:~$ sudo apt-get install python3.4
Reading package lists... Done
Building dependency tree 
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
python3.4 : Depends: python3.4-minimal (= 3.4.0-2ubuntu1) but it is not going to be installed
Depends: libpython3.4-stdlib (= 3.4.0-2ubuntu1) but 3.4.1-1+precise1 is to be installed
E: Unable to correct problems, you have held broken packages.
dave@Threepwood:~$ sudo apt-get install python3.4-minimal
Reading package lists... Done
Building dependency tree 
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
python3.4-minimal : Depends: libpython3.4-minimal (= 3.4.0-2ubuntu1) but 3.4.1-1+precise1 is to be installed
Recommends: python3.4 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Synopsis of the above command prompt output with the relevant bits:

Code:
sudo apt-get install update-manager
Depends: python3 but it is not going to be installed

sudo apt-get install python3
Depends: python3.4 (>= 3.4.0-0~) but it is not going to be installed

sudo apt-get install python3.4
Depends: python3.4-minimal (= 3.4.0-2ubuntu1) but it is not going to be installed

sudo apt-get install python3.4-minimal
Depends: libpython3.4-minimal (= 3.4.0-2ubuntu1) but 3.4.1-1+precise1 is to be installed
So ultimately it appears to fail because it is expecting python3.4-minimal, but the library is actually called "python3.4.1-1+precise1"? Is this correct?

Can anyone suggest anything?

Last edited by cov; 08-21-2014 at 10:47 AM.
 
Old 08-22-2014, 04:05 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Have you run the following command from a terminal and then tried to install the update-manager?
Code:
sudo apt-get update
jdk
 
Old 08-22-2014, 04:14 AM   #3
cov
Member
 
Registered: Apr 2005
Location: Durban
Posts: 436

Original Poster
Rep: Reputation: 30
Hi JDK.

The solution was to uninstall libpython3.4 and libpython3.4-minimal and then try again.

Apparently the versions I had installed were non-standard versions acquired through the PPA independent software version system. (I had been trying to implement the Yafaray raytracer on Blender which used incompatible versions of Python).

Anyway, I'm now sorted.

Thanks.

~ Dave
 
Old 08-22-2014, 11:24 PM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
I'm glad you sorted it out. As a service to others please mark this thread as [SOLVED]. You can use the Thread Tools menu located above your first post in this thread (see the attachment).
jdk
Attached Thumbnails
Click image for larger version

Name:	lq_threadtools.png
Views:	456
Size:	26.8 KB
ID:	16184  
 
  


Reply

Tags
python dependency


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] PyQt for Python3? rshepard Slackware 13 08-03-2016 10:53 AM
Python3 on Cygwin AsherM Linux - Newbie 6 09-14-2013 03:25 PM
[SOLVED] Python3 shelve UnicodeDecodeError vmsda Programming 2 05-03-2013 03:32 AM
[SOLVED] Python3.2 vs yum hpfeil Fedora 4 08-01-2012 10:51 AM
[SOLVED] how to run bpython with python3? saavedra29 Slackware 2 03-08-2012 07:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration