LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-05-2004, 07:54 AM   #1
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Rep: Reputation: 30
Python Upgrading


hello
Any one know how to upgrade "python", which mailman (mailing list manager software) required , by default sysetm has old version


i search old versions with
whereis python, the result was

/usr/bin/python1.5 /usr/bin/python /usr/bin/python2.2 /usr/lib/paython1.5

it it show that system has python 2.2 but i thing default is 1.5 thats why when i run ./configure for mailman it say python 2.1 or new is reqired

i have downloaded new python 2.3.4 in tar format , how to upgrade it .

thanks
waiting fro reply
 
Old 08-05-2004, 08:30 AM   #2
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Original Poster
Rep: Reputation: 30
hello
In the python help docs the recomend comand for installation is:

python setup.py build
python setup.py install
OR
python setup.py install

But is says :
File "setup.py", line 79
extlist = [ext for ext in extlist if ext.name == nodname]
SyntaxError: invalid syntax

i dont know why its saying

if some one know guied me

regards
 
Old 08-06-2004, 01:14 AM   #3
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Original Poster
Rep: Reputation: 30
Still waiting for reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Processing Conflict: python-devel conflicts python< 2.3.4-13.1 guarriman Fedora 2 04-23-2009 07:02 PM
installing python library's (Python Numeric) Four Linux - Newbie 1 10-16-2005 02:31 PM
Upgrading python on FC2? Phaethar Fedora 0 08-18-2004 07:30 AM
Upgrading Python to newer version dopper Linux - Software 3 02-19-2004 12:10 PM
install python 2.3 ,necssary to remove python 2.2 ngan_yine Linux - Newbie 7 12-28-2003 04:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration