-   Linux - Software (
-   -   python+GTK+Compiz (

tpariel 12-01-2007 02:01 PM

hi all,

I just upgraded to Gutsy and I was trying to install the Compiz. Every thing seems to be ok until I tried to run the ccsm and I got the following message:

talavera@talavera-laptop1:~$ ccsm
Traceback (most recent call last):
File "/usr/bin/ccsm", line 24, in <module>
import gtk
File "/var/lib/python-support/python2.5/gtk-2.0/gtk/", line 48, in <module>
from gtk import _gtk
ImportError: /usr/lib/ symbol png_set_expand_gray_1_2_4_to_8, version PNG12_0 not defined in file with link time reference

After some walking around the problem and by coincidence I ran the pygtk-demo command and I got exactly the same error.

Please, could you help me with this? I do not what else to do ???

manicmike 01-20-2011 04:42 PM

Sometimes this still happens
Well, years later I got the same error but with python 2.6 running.

The problem was that I had two versions of libpng12 installed. One was quite old, from an installation of lightscribe simple labeler. The system loaded it when I started update-manager and immediately died. Starting it from the command line gave the relevant error.
FIX: I edited /etc/ to add /lib and /usr/lib then ran sudo ldconfig. update-manager instantly started working again. I could also have disabled or deleted the lightscribeApplications.conf in but then lightscribe may not work. Hope this helps someone.

All times are GMT -5. The time now is 03:00 PM.