-   Linux - Software (
-   -   pure-ftpd does not start correctly when booting (

wouterzzzzz 12-31-2006 09:10 AM

pure-ftpd does not start correctly when booting
I installed and configured pure-ftpd and when I start the server from the terminal it all seems to work smoothly (I can login, browse to the appropriate directories (using symbolic links) etc).

Now I would like to startup the server when my pc boots. I tried selecting pure-ftpd in the "Sevices" option within GNOME and ajusting the .conf file to reflect my command line options. The problem is that I also want to have a pure-uploadscript attached to my server (so the server needs to start with the -o parameter). Trying to start te server this way gives an error during startup (the pipe could not be created or something like that).

So I tried to include two lines in rc.local: one to start the server (including -o) and one to start pure-uploadscript. Again, this does not work properly: a pure-ftpd process is started, but no pure-uploadscript. When I login to the server, I do not have permission to follow the links (which is possible when the server is started from the terminal).

I'm a bit out of ideas right now. Just started using Linux about a week ago, so I still have a lot to learn :) Can anyone help me with this?

Right, some additional info: using Fedora Core 6, x86_64.

Mod Note:
Moving to Linux - Software to get the thread the exposure it deserves.
//Mod Note

All times are GMT -5. The time now is 11:53 PM.