-   Linux - Software (
-   -   pulseaudio interrupts and throttles (

wilku 08-14-2009 11:55 AM

pulseaudio interrupts and throttles

I have some problems with sound on OpenSuse 11.1. The sound server is PulseAudio. When I watch divx movies in vlc (sometimes also flash movies in firefox) after some time, especially when something is happening (much picture changing) the sound interrupts for split second and never returns to continuous flow, It keeps interrupting and regaining synchronization. I have to pause for a moment and then it returns to normal. It didn't happen earlier with alsa alone on OpenSuse 11.0. It's a fairly old laptop so I suppose it could be some problems with real time playing, but with earlier versions and other systems it worked all right. Any thoughtson this? It starts to be a little annoying.


antiussentiment 08-15-2009 10:47 PM

you're doing better than me then..
I've just done a system update (SuSE 11.0) and all my audio is gone.

when i fiddle with stuff in the yast settings i can hear some scratchy/clicks in my speakers. but none of the test sounds work, flash will play in my browser with no sound, rhythm box only pretends to play (no sound)..

i've removed pulse audio as i saw other folk complaining about it. and tried to go back to alsa only.. restarted the sound server.. but no luck..

maybe i should upgrade to 11.1? though i think i'd rather nut this out.


mushroomboy 08-16-2009 06:13 AM

OSSv4, OSSv4!!! It is way better than ALSA/Pulse, well ok maybe not 100% way better, but it's a really good solution.

All times are GMT -5. The time now is 04:10 AM.