-   Linux - Software (
-   -   Programs cannot find GTK+-2.0 (

scott4957 10-04-2005 10:07 PM

Programs cannot find GTK+-2.0
I have the GTK+ library installed "Name: gtk+2.0 Version: 2.6.4-2mdk" on Mandriva 10.2

When i try to install software that requires gtk+2.0 such as airsnort in this example I get this message or something similar.

checking for pkg-config... /usr/bin/pkg-config
checking for gtk+-2.0 >= 2.0.0... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found

configure: error: Library requirements (gtk+-2.0 >= 2.0.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

This is the result from ./configure of the airsnort package, nothing is ever able to find gtk. Anyone have any ideas? Thanks, and i am a noob so be specific please!


__J 10-05-2005 12:00 AM

look on your install cd's or use urpmi to find the corresponding devel package for gtk-2.x, it'll be something along the lines of gtk2-2.6.x-devel-i686.rpm ( package names vary from distro to distro).

being an rpm distro, Mandrake split's it's packages, the first is the library portion ( libraryxxx.rpm), the other is the development files portion (libraryxxx-devel.rpm). These files are not needed to actually use the library, but to compile against it they are required. One of these files will be the .pc file, the file pkg-config is looking for to determine if you meet the requirements of the software you are trying to build.

__J 10-05-2005 12:01 AM

sorry double post.

reddazz 10-05-2005 06:16 AM


#urpmi libgtk+2.0_0-devel

scott4957 10-05-2005 11:19 AM

I was not able to find what i needed in the supplied packages for Mandriva linux LE 2005. I will list what i have loaded when I go into the Mandrake Control center and remove packages by searching for GTK. This should be the packages that i have loaded.

libgtkhtml “another version”
perl-gtk2 “times 3”

It seems i may have two different versions of GTK running, could this be my problem?

Reddazz i tried to install libgtk+2.0_0-devel from a website but received the following error:

Some package requested cannot be installed:
(due to unstaisfied libgtk+2.0_0[==2.8.3

Any ideas guys? Thanks again.

__J 10-05-2005 03:06 PM

the package you were trying to install is a higher version than the library is, so it won't work. try urpmi like reddazz suggested ( google for easyurpmi to set it up, once you do it will save you alot of time). Most of the problem is the LE edition is not set up to compile software from source, it's more meant to use binary packages.

scott4957 10-05-2005 04:08 PM

Great, thanks for the help. I set up urpmi via easyurpmi web site, then downloaded the correct development package for GTK, it was able to find GTK after that. Thanks again for all the help!


reddazz 10-06-2005 11:21 AM

On Mandriva, try not to download packages manually, use the urpmi tool or its gui (rpmdrake) to manage packages. Make sure you update your urpmi sources regularly.

All times are GMT -5. The time now is 07:26 AM.