LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-03-2003, 09:11 PM   #1
Raw Kuts
LQ Newbie
 
Registered: Jul 2003
Location: San Diego, CA
Distribution: Mandrake 9.1
Posts: 7

Rep: Reputation: 0
ProFTPd on bootup with xinetd


I am using Mandrake 9.1 and I am not using the RPM of proftpd, I downloaded 1.2.8 and installed it with the default options. It went into /usr/local/bin, /usr/local/sbin and /usr/local/etc. I just left it there, should I move the stuff to the /bin, /sbin and /etc? Would that effect anything?

I configured proftpd so I can log in and update my apache server and browse shares on my windows machines (thanks to the older posts in this forum). The only thing was I had to start it up every time I restarted the computer. So I wanted it to run when the computer was started. So I changed the type from standalone to inetd, and added an entry to /etc/xinetd.d/proftpd. When I rebooted I couldn't log into the ftp. I am assuming it is because proftpd didn't start. What else do I have to do to get proftpd to start on bootup (I am not against using standalone on bootup, I just don't know how).

One other thing I looked at was the log files for proftpd, and all that was in there was the last time I started it up in standalone mode. So I assume it is not even starting in with xinetd. When I looked at my system log, the only error I could find was this. I get fairly late into the bootup stage (right before the stuff in my rc.local runs I think).
Code:
Aug  3 18:41:55 rawkuts xinetd[3265]: warning: can't get client address: Transport endpoint is not connected
Aug  3 18:41:55 rawkuts xinetd[3265]: libwrap refused connection to sgi_fam from <no address>
Aug  3 18:41:55 rawkuts xinetd[1125]: Deactivating service sgi_fam due to excessive incoming connections.  Restarting in 30 seconds.
I get about 25 of those warnings and libwrap refused before it says it deactivates sgi_fam. Is something that is stopping proftpd from running?

Here are my conig files:
Code:
/etc/xinetd.d/proftpd
service ftp
{
	disable 	= no
	flags 		= REUSE
	socket_type 	= stream
	wait 		= no
	user 		= root
	server 		= /usr/local/sbin/proftpd
	log_on_success 	+= HOST DURATION USERID
	log_on_failure 	+= HOST RECORD USERID
	nice 		= 10
}
Code:
/usr/local/etc/proftpd.conf
ServerName		"You should not see me"
ServerType		inetd
DefaultServer		off

Umask			022
MaxInstances		24

User			nobody
Group			nogroup
DefaultRoot 		~

SystemLog		/var/log/proftpd.system.log
TransferLog		/var/log/proftpd.xfer.log

<Limit LOGIN>
	DenyAll
</Limit>

<Global>
	MaxClients		12 "%m Already logged in"
	MaxClientsPerHost	2 "You can only log in %m times"
	DisplayLogin		welcome.msg
	DisplayFirstChdir	.message
	AllowForeignAddress 	off
	TimeoutIdle		200
	TimeoutNoTransfer	120
	TimeoutLogin		80
	AllowOverwrite		on
	AllowStoreRestart	on
	AllowRetrieveRestart	on
	DeleteAbortedStores	off
	HiddenStor		off
</Global>

<VirtualHost 192.168.1.243>
	Port			1203
	#DataPort		1202
	ServerName		"Apache Manage Server"
	DefaultRoot		/home/httpserver/apache2
	User			httpserver
	Group			httpserver
	MaxClients		1
</VirtualHost>

<VirtualHost 192.168.1.243>
	Port			1205
	#DataPort		1204
	ServerName		"FTP Manage Server"
	DefaultRoot		/home/ftpserver/base
	User			ftpserver
	Group			ftpserver
	MaxClients		1
</VirtualHost>
 
Old 08-04-2003, 01:42 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
libwrap points to tcpwrapper - /etc/hosts.allow and /etc/hosts.deny.
 
Old 08-03-2006, 11:44 PM   #3
JorgeParedes
LQ Newbie
 
Registered: Aug 2006
Location: Lima, Perú
Distribution: Debian
Posts: 2

Rep: Reputation: 0
If it helps, to run proftpd standalone you have to specify so in proftpd.conf:

ServerName "You should not see me"
ServerType standalone
DefaultServer off
...

Besides, I think that

<Limit LOGIN>
DenyAll
</Limit>

denies any login, so, assuming you want to preserve the least privilege spirit, you could modify it this way (for example):

<Limit LOGIN>
Allow from 128.44.26.,128.44.26.,myhost.mydomain.org
DenyAll
</Limit>

Best regards...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd can't be launched from xinetd pelletie Linux - Newbie 3 08-26-2008 02:54 PM
proFTPd using XINETD HELP!! sc_3007 Linux - Networking 2 08-03-2006 03:55 PM
proftpd will not run under xinetd jon_k Linux - Software 1 12-18-2004 05:14 AM
proftpd and xinetd pfunk Linux - Networking 1 12-08-2004 01:59 AM
Need Help With Getting ProFTPd Started via XINETD John_Saunders Linux - Software 4 07-23-2002 10:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration