LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-02-2003, 12:03 AM   #1
kdogg
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
ProFTPd Crashing?


im sure a lot of people have had this problem but this is the first time ive ever heard about something like this let alone experienced it. heres the situation:

there is (according to multiple "ps") commands no running proftpd server. however, i do the following commands and this is what i get from the shell:

[root@localhost root]# /etc/rc.d/init.d/proftpd status
proftpd dead but subsys locked

and

[root@localhost root]# proftpd -n -d2
- parsing '/etc/proftpd.conf' configuration
- <Directory />: adding section for resolved path '/'
localhost.localdomain - getnameinfo error: ai_family not supported
localhost.localdomain - Failed binding to (null), port 21: Address already in use
localhost.localdomain - Check the ServerType directive to ensure you are configured correctly.

i checked the servertype and it is set to "standalone" like it normally is. i tried asking multiple people but i dont get a straight answer . any thoughts?
 
Old 10-10-2003, 03:50 PM   #2
samkor
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
I came across the same problem after updating my ProFTP version to 1.2.9rc2 (I noticed only afterwards that this was a testing release). I'm still trying to figure out how to solve the problem. One solution might be to return to use the 1.2.8 version which worked just fine.

Well, I know this wasn't very informative but at least your not alone with the problem.
 
Old 04-01-2004, 12:08 PM   #3
VincentB
Member
 
Registered: Jun 2003
Location: Brussels, Belgium
Distribution: Ubuntu 6.10
Posts: 139

Rep: Reputation: 15
I had the same problem.

Apr 1 19:02:25 sun proftpd[3802]: sun.xxxx.be - Failed binding to 0.0.0.0, port 21: Address already in use
Apr 1 19:02:25 sun proftpd[3802]: sun.xxxx.be - Check the ServerType directive to ensure you are configured correctly.

[root@sun xinetd.d]# netstat -tanp
Connexions Internet actives (serveurs et établies)
Proto Recv-Q Send-Q Adresse locale Adresse distante Etat PID/Program name
tcp 0 0 127.0.0.1:32768 0.0.0.0:* LISTEN 3001/fam
tcp 0 0 0.0.0.0:32769 0.0.0.0:* LISTEN -
tcp 0 0 0.0.0.0:2049 0.0.0.0:* LISTEN -
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 2471/mysqld
tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN 2493/smbd
tcp 0 0 0.0.0.0:683 0.0.0.0:* LISTEN 1350/ypserv
tcp 0 0 0.0.0.0:685 0.0.0.0:* LISTEN 2201/rpc.mountd
tcp 0 0 0.0.0.0:654 0.0.0.0:* LISTEN 2170/rpc.rquotad
tcp 0 0 127.0.0.1:783 0.0.0.0:* LISTEN 2384/spamd -d -c -a
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1269/portmap
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2656/httpd2
tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 2475/perl
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN 1940/X
tcp 0 0 0.0.0.0:785 0.0.0.0:* LISTEN 1878/rpc.ypxfrd
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 3973/xinetd
tcp 0 0 192.168.1.100:53 0.0.0.0:* LISTEN 1961/named
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 1961/named
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1985/sshd
tcp 0 0 0.0.0.0:23 0.0.0.0:* LISTEN 3973/xinetd
tcp 0 0 0.0.0.0:631 0.0.0.0:* LISTEN 2078/cupsd
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2364/master
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 1961/named
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 2656/httpd2
tcp 0 0 0.0.0.0:668 0.0.0.0:* LISTEN 1334/rpc.statd
tcp 0 0 0.0.0.0:7741 0.0.0.0:* LISTEN 2696/lisa


The problem was due to the fact that inetd was listening of port 21, which is precisely the port use by proftp.

Here is the content of my the proftpd.conf file:

[root@sun etc]# more /etc/proftpd.conf
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName "ProFTPD Default Installation"
ServerType inetd
DefaultServer on

# Allow FTP resuming.
# Remember to set to off if you have an incoming ftp for upload.
AllowStoreRestart on

# Port 21 is the standard FTP port.
Port 21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances 30

# Set the user and group under which the server will run.
User nobody
Group nogroup

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
#DefaultRoot ~

# Normally, we want files to be overwriteable.
<Directory />
AllowOverwrite on
</Directory>

# Needed for NIS.

PersistentPasswd off

# Default root can be used to put users in a chroot environment.
# As an example if you have a user foo and you want to put foo in /home/foo
# chroot environment you would do this:
#
# DefaultRoot /home/foo foo
Include /etc/proftpd-anonymous.conf


My problem came from Servertype which was Standalone and which should have been inetd (as I use inetd and do not run proftpd as daemon)

Finally, my proftpd-xinetd file looks like this:

[root@sun etc]# more /etc/xinetd.d/proftpd-xinetd
# default: off
# description: proftpd server, xinetd version. \
# Don't run the standalone version if you run \
# this!
service ftp
{
disable = no
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.ftpd
log_on_success += DURATION USERID
log_on_failure += USERID
nice = 10
}


I have also deleted the FTP file from that directory.
Now you just have to adapt proftpd.conf file in order to grant / deny access to users.
I have spent evenings during 2 weeks trying to solve this. Hope this will also work fine for you with those indications.

Regards,
Vincent
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd: proftpd startup failed tumana Linux - Newbie 14 06-17-2012 11:06 AM
[PROFTPD] Ldap and proftpd authentication wesleywest Linux - Software 1 02-22-2005 09:51 AM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 10:27 AM
PC keeps crashing Badut Linux - Newbie 1 04-26-2004 10:41 PM
proftpd --- need help? could someone post a working proftpd.conf i could look at ZooRoPa Linux - Networking 1 04-02-2003 06:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration