LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-17-2012, 03:11 AM   #1
paulbom
LQ Newbie
 
Registered: Feb 2012
Location: Soligny, France
Distribution: Cygwin, Debian
Posts: 8

Rep: Reputation: Disabled
Procmail : incoming mail stored outside inbox/new


I use fetchmail, procmail and mutt under Cygwin. Now, I'd like procmail to handle separately my different accounts.
To begin with,
  • I moved the "sit" maildir to ~/mail/sit/ ;
  • created a conffile : ~/.procmail/sit.pmrc ;
  • added a line in .fetchmailrc that points to it : mda "/usr/bin/procmail -t -m ~/.procmail/sit.pmrc" ;
  • and set "invisible"
Now, incoming mail does arrive in ~/mail/sit/Inbox, but outside ~/mail/sit/Inbox/new (where I would expect):
Code:
$ ls mail/sit/Inbox/
cur/  msg.Q9L  msg.bUn  msg.cUn  msg.dUn  new/  tmp/
Could anyone give me a help ?

Here are my current settings :
Code:
# ~/.fetchmailrc
set daemon 900
set logfile .fetchmail-error
set syslog
set invisible
# First account (sit)
poll *** with proto pop3 username *** password *** keep
mda "/usr/bin/procmail -t -m ~/.procmail/sit.pmrc"

# ~/.procmail/sit.pmrc
MAILDIR=$HOME/mail/sit
DEFAULT=$MAILDIR/Inbox
LOGFILE=$HOME/.procmail.log
...
# rules (basic test)
:0
* ^TO(sit|logcheck|root)@*****.fr
$DEFAULT

:0
* ^To:.*lists.debian.org
$DEFAULT

:0:
$DEFAULT

EXITCODE=75
:0
/dev/null

Last edited by paulbom; 02-17-2012 at 03:19 AM.
 
Old 02-17-2012, 03:24 AM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Welcome to LQ

Did you restart fetchmail and procmail after the changes?
Any pointers in the logfiles?
Try to add
Code:
VERBOSE = on
in the procmail.rc file

Kind regards
 
Old 02-17-2012, 03:34 AM   #3
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,099

Rep: Reputation: 344Reputation: 344Reputation: 344Reputation: 344
Hi there,

Quote:
Originally Posted by paulbom View Post
Now, incoming mail does arrive in ~/mail/sit/Inbox, but outside ~/mail/sit/Inbox/new (where I would expect):
Code:
$ ls mail/sit/Inbox/
cur/  msg.Q9L  msg.bUn  msg.cUn  msg.dUn  new/  tmp/
if you want procmail to deliver correctly into a maildir, you have to specify the directory name with a trailing slash in procmail's config.

Quote:
Originally Posted by paulbom View Post
Code:
MAILDIR=$HOME/mail/sit
DEFAULT=$MAILDIR/Inbox
Try $MAILDIR/Inbox/ - that should do the trick.

[X] Doc CPU
 
1 members found this post helpful.
Old 02-17-2012, 04:03 AM   #4
paulbom
LQ Newbie
 
Registered: Feb 2012
Location: Soligny, France
Distribution: Cygwin, Debian
Posts: 8

Original Poster
Rep: Reputation: Disabled
Thanks for your concern !
I did restart fetchmail daemon. Procmail is directly invoked by fetchmail, so I didn't do anything (but I certainly restarted windows7 to apply any new patch since yesterday !)

As for the logs, I don't see anything special :
Before the change I got : Folder: sit/Inbox/new/1329246880.7088_1.pcpaul
And now just : Folder: /home/paul/mail/sit/Inbox/msg.dUn

I also tried $DEFAULT/new instead of $DEFAULT in .procmail/sit.pmrc : it works, but it's nothing but a workaround.
 
Old 02-17-2012, 04:39 AM   #5
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,099

Rep: Reputation: 344Reputation: 344Reputation: 344Reputation: 344
Hi there,

Quote:
Originally Posted by paulbom View Post
I also tried $DEFAULT/new instead of $DEFAULT in .procmail/sit.pmrc : it works, but it's nothing but a workaround.
that's not what I said, and not what I meant, either.
Just specify the mail directory ($DEFAULT/Inbox in your setup) and add a trailing slash. Nothing more.

[X] Doc CPU
 
Old 02-17-2012, 09:42 AM   #6
paulbom
LQ Newbie
 
Registered: Feb 2012
Location: Soligny, France
Distribution: Cygwin, Debian
Posts: 8

Original Poster
Rep: Reputation: Disabled
To DOC CPU : Thanks for the Tip, that's it !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Mail Server: cant deliver mail in Users Inbox madfed Linux - Server 1 06-14-2009 06:08 AM
Squirrel Mail is not sending mail in INBOX MajazKhan Linux - Server 1 04-08-2007 07:57 AM
How to get incoming e-mails to go to IMAP inbox? capitalista Linux - Networking 1 12-11-2005 10:50 PM
Sendmail Not Show Mail in Inbox (Evalution Mail) skanand Linux - Networking 1 05-11-2005 01:22 AM
Postfix $HOME/mail/inbox instead of /var/spool/mail ramram29 Linux - Software 3 08-08-2004 02:28 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration