LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 10-20-2009, 12:11 AM   #1
wlchak
LQ Newbie
 
Registered: Oct 2009
Location: Singapore
Posts: 12

Rep: Reputation: 0
Problems witn Installing Nagios on RedHat Linux 4,0


Hi All,

I encountered the following problems installing Nagios 3.0 on RedHat Linux 4.0:

1. /usr/local/nagios/bin directory was not created during installation, any idea why?

2. Nagios cannot be started when i use command: service nagios start
Error shows: executable file /usr/local/nagios/bin/nagios not found. exiting..

Im using Nagios 3.2.0 for Core Installer, and Nagio 1.4.14 for Plugin.

Pls advise..

Thank you.
 
Old 10-20-2009, 01:01 AM   #2
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,183

Rep: Reputation: 113Reputation: 113
Have you received any error when you were compiling the nagios, if everything fine then there should be bin directory at your prefix location.

Quote:
/usr/local/nagios/bin directory was not created during installation
Are you pretty sure that /usr/local/nagios is the prefix location?
Can you find some other directories than bin?
 
Old 10-20-2009, 03:54 AM   #3
wlchak
LQ Newbie
 
Registered: Oct 2009
Location: Singapore
Posts: 12

Original Poster
Rep: Reputation: 0
Hi Kirukan,

Yes, the prefix location is /usr/local/nagios as i can see other directories like etc, include, share, var, libexec
under /usr/local/nagios. Seemed to me, all are in place, except the /usr/local/nagios/bin dir is missing.

Can you share more information about what you mean by compiling nagios? Did you mean installing nagios?
I have not encountered any errors while installing nagios. And i did all the necessary steps: make all, make install, make install-config, make install-commandmode.

I also did not encounter any errors while installing the Nagios Plugin too.

What would you advise that i should do now? Should i reinstall Nagios all over again?
And is there a way i can uninstall nagios? Or do i need to actually reinstall the Red Hat Linux OS?

Thank you.
 
Old 10-20-2009, 04:17 AM   #4
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,183

Rep: Reputation: 113Reputation: 113
I have installed the same nagios version in RHEL5.2 it's working fine, however can you reinstall it again? Because you are saying that you didn't face any error when you were installing the nagios
 
Old 10-20-2009, 05:07 AM   #5
wlchak
LQ Newbie
 
Registered: Oct 2009
Location: Singapore
Posts: 12

Original Poster
Rep: Reputation: 0
Hi Kirukan,

Yeah.. re-installing all over again would be a good option since troubleshooting from the current installed one is going
to be very tough.

Would you share which online Nagios installation guide did you refer to when you did your installation? It would be great to be able to refer to the installation instructions for RHEL.
Am using RHEL 4.0.

Thank you very much.
 
Old 10-20-2009, 08:39 AM   #6
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,183

Rep: Reputation: 113Reputation: 113
Download the official document from nagios site because that is well documented.
check this
http://support.nagios.com/knowledgebase/officialdocs
 
Old 01-24-2013, 02:20 AM   #7
Divya V N
LQ Newbie
 
Registered: Jan 2013
Posts: 3

Rep: Reputation: Disabled
Question /usr/local/nagios/bin is not found

Hi wlchak,

I am facing the same poblem as you did, while installing Nagios 3.4.4 on Ubuntu 12.04:
When I reload apache I am getting an error that /usr/local/nagios/bin is not found.

Did you find a way around it? If so, please help me.

Thank you in advance!
 
Old 01-24-2013, 05:16 AM   #8
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5
Posts: 16,086

Rep: Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995
The thread is from 2009; please start a new thread.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to get etc directory while installing NAGIOS in Redhat 9 mayankh Linux - Software 1 11-18-2006 04:56 PM
Nagios configuration on redhat linux help needed !!! apache Linux - Software 2 09-14-2004 11:02 AM
Boot problems witn Mandrake 10 and Windows 2000 lala52 Mandriva 5 06-19-2004 08:46 AM
Problems installing RedHat Database 2.1 on Redhat Linux 9 bkimelman Linux - Software 0 10-18-2003 01:32 PM
problems with installing linux redhat pawan sharma Linux - General 2 10-04-2003 06:11 PM


All times are GMT -5. The time now is 09:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration