-   Linux - Software (
-   -   Problems with wine after upgrade (

vdemuth 12-13-2004 03:01 PM

Problems with wine after upgrade
Hi all,
Have just upgraded my box to the latest Slack but now I canīt run wine. Get the error below.
Anyone any ideas. I have installed the latest wine from the Slack mirror sites as well, but the same error occurs.

wine: failed to initialize: /usr/lib/wine/ failed to map segment from shared object: Cannot allocate memory


vdemuth 12-14-2004 02:19 PM

Just compiled from source with exactly the same error, anyone know if this is a bug that should be reported to the people at wine, or a problem with my box?

mhearn 12-18-2004 11:54 AM

It's some kind of kernel/glibc issue I'd imagine. I'd talk to the Mandrake people.

vdemuth 12-19-2004 04:07 AM

I would do, but the problem is with Slack. However, I have rolled back my wine to version 20040505, and it runs fine, so the problem definately lies with wine 20041201. I have opened a bug report at wine in the hope of getting an answer

mhearn 12-19-2004 06:06 AM

No, the problem is almost certainly a kernel/fs/glibc issue. I am a Wine developer, the message is being generated by the underlying Linux linker not by us.

vdemuth 12-19-2004 02:38 PM

Then as a developer, can you please explain why a previous version works just fine.
Now I may not be a developer, in fact I know sweet F.A. about writing software, but I do hold a Bsc.Hons in electronics, and am fully aware that things can go wrong. I am also willing to accept that the best designs in the world can at times falter, even when I have helped in that design. By you saying it is almost certainly a kernel/fs/glibc issue sems to me at least to be sidestepping the real problem here, and that is that the latest version may contain a bug causing this error. It brings to mind that other great quote about a certain unsinkable ship that proved to be anything other than that, with dire consequences. Now do not get me wrong, I am not likening Wine to the Titanic, as that would be just a little trite, I am just looking for answers to the problem as to why the latest version dies with the error shown. Maybe you would like to reconsider your response and pass this error onto the other developers just in case.

mhearn 12-19-2004 03:47 PM

What version of Wine were you using before? Where are you getting your packages? Does this work if you install from source?

Just because a newer version doesn't work does not mean the issue is with Wine. It may mean Wine is doing something now that should work but doesn't on your system for whatever reason.

I'd try different means of installing it and see if that clears it up.

vdemuth 12-20-2004 01:22 AM

Got wine from the wine depository at sourceforge, downloaded the new version, 20041201, did the usual ./configure, make depends && make, su to root, then make install. No errors reported. Tried to use it with my existing wine config file, no joy, just the error about Tried a new config file based on the example included with the same error. Downloaded again, just in case the first D/L was corrupted somehow, same results. All of this having first removed the previous version I was using (20040505), except for the config file of course.
So I then removed this new version, went through the process of compiling/building the previous version once again, and I can only report that it works just as it always did, without any drama, using my origional config file etc. The only logical conclusion therefore, would seem to be that the error lies somewhere within the latest version, as everything else remains a known and working constant. Do you have any more ideas?

vdemuth 05-24-2005 09:48 AM

Right, here goes.
Got the very latest wine from winehq. Installed it using the install script included with the software. All this in an attempt to run MS messenger (Don't ask)
I get exactly the same error as at the beginning of this thread.Namely, wine: failed to initialize: /usr/lib/wine/ failed to map segment from shared object: Cannot allocate memory.
Is there anyone at all who can shed light on this in a constructive manner. Once again, rolling back to wine 20040505 allows wine to work, but unfortunately MS Messenger wont work under that version either. Or, am I beating a dead horse here, and wine is just not all it's reported to be, and ought to be avoided like the plague?

All times are GMT -5. The time now is 02:43 AM.