LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   problems with rpm (https://www.linuxquestions.org/questions/linux-software-2/problems-with-rpm-103231/)

talkinggoat 10-12-2003 08:55 PM

problems with rpm
 
every time that i try to do a rebuild using rpm from a src rpm, i get the following:

[root@lnuxbox SOURCES]# rpm --rebuild bison-1.35-4.src.rpm
bison-1.35-4.src.rpm: No such file or directory

the src rpm is in the sources directory, but, no matter what i do, it will not install.

i created all the directories listed in the RPM_HOWTO, to no avail. i have even tried using the -b switch. it gives me the same error. what am i doing wrong? are there directories that are supposed to exist before i run the --rebuild command, or, poossibly things that have to be done?

iamthewind 10-12-2003 10:49 PM

you can try this:
# rpm -i bison-1.35-4.src.rpm
and then go to directory /usr/src/redhat/SPECS to
build bison.SPECS using : # rpm build -bp bison*.SPECS
then,go to directory /usr/redhat/BUILD/bison*/ to configure
using : # ./configure you can give some parameter
then : # make
# make install
I wish this is useful to u , I am a newer,if it have some problem ,please tell me !

talkinggoat 10-12-2003 11:02 PM

[root@lnuxbox SPECS]# rpm build -bp bison.spec
bison.spec: No such file or directory


All times are GMT -5. The time now is 08:11 AM.