LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-18-2005, 02:57 PM   #1
einstien
Member
 
Registered: Sep 2004
Distribution: fedora
Posts: 98

Rep: Reputation: 15
problems with nessus


hallo i installed nessus a couple of days a go....
but then when i restarted my computer and enterd the program and then i preesed connect and it said it cant connect... so i uninsatlled it and the install it agian...
but it still didnt work i registerd in the site and i downloaded the plugins every thing like i should and like the first time when i installed it.... but it doesnt connect... and when i run nessusd to load the plugins it tells me

Quote:
[root@localhost sbin]# /usr/nessus/sbin/nessusd
Loading the plugins... 1224 (out of 7234)
All plugins loaded
bind() failed : Address already in use
what can i do? why wont it connect?
 
Old 03-18-2005, 03:51 PM   #2
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
have you run the programs like nessus-config, nessus-mkcert, nessus-adduser?

Are you using fedora like your profile says? If you are using fedora core 3 there are some rpms you can install. http://atrpms.net/dist/fc3/nessus/
 
Old 03-18-2005, 09:10 PM   #3
einstien
Member
 
Registered: Sep 2004
Distribution: fedora
Posts: 98

Original Poster
Rep: Reputation: 15
willl ammm i do use fc3... but i dont need an rpm package i need a solution...

why when i first installed it it worked fine???? and now it wont connect?
 
Old 03-18-2005, 11:22 PM   #4
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
Do this as root on the command line:

ps aux | grep -i nessusd

Is it already running? When I installed nessus it added a startup script to start the daemon that I had to disable later.

I ran an experiment where I started it using the startup script. After that I tried to run nessusd and got the same results as you. Otherwise it works fine.

Code:
[root@fedora nessus]# /etc/init.d/nessusd start
Starting nessusd:                                          [  OK  ]
[root@fedora nessus]# nessusd
All plugins loaded
bind() failed : Address already in use
[root@fedora nessus]# ps aux|grep nessus
root      4635  0.0  1.1  7172 4532 ?        Ss   22:16   0:00 nessusd: waiting for incoming connections
root      4683  0.0  0.1  3644  652 pts/0    R+   22:21   0:00 grep nessus
[root@fedora nessus]#
If your client is still not connecting you should try to run it as whatever you ran it as the first time when it worked (root or a regular user)

Last edited by benjithegreat98; 03-18-2005 at 11:26 PM.
 
Old 03-19-2005, 10:05 AM   #5
einstien
Member
 
Registered: Sep 2004
Distribution: fedora
Posts: 98

Original Poster
Rep: Reputation: 15
ok

ok the first time i ran it with the same user im running now.... now look i did the command you said

Quote:
[root@localhost ~]# ps aux | grep -i nessusd
root 700 0.0 1.3 11044 6796 pts/3 S+ Mar18 0:33 nessusd: waiting for incoming connections
root 30580 0.0 0.1 4116 688 pts/5 R+ 16:54 0:00 grep -i nessusd
and this is what it wrote me... now... how do i stop it? i mean you said it run on startup.. so how do i stop it from happining?
 
Old 03-19-2005, 11:45 AM   #6
einstien
Member
 
Registered: Sep 2004
Distribution: fedora
Posts: 98

Original Poster
Rep: Reputation: 15
never

never mind i used kill and now the program is runing fine
 
Old 03-19-2005, 10:34 PM   #7
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
Glad you got it working. If you would like to set it where it does not start up when FC3 starts up, go to the redhat menu > System Settings > Server Settings > Services. See if nessus is listed. You can uncheck it if it is in there. If it isn't there check in /etc/rc.d/rc.local .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Nessus Kursh Linux - Security 1 08-28-2005 01:08 PM
Nessus install script not finding nessus.tar.gz darin3200 Linux - Software 1 08-15-2005 06:35 PM
Nessus install problems zuessh Linux - Software 5 10-22-2003 10:08 AM
problems installing Nessus ??? BrokenArrow Linux - Software 4 11-15-2002 09:30 AM
Problems compiling nessus kud0ze Linux - General 2 10-31-2001 03:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration