LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problems with Konqueror (https://www.linuxquestions.org/questions/linux-software-2/problems-with-konqueror-85722/)

JoeDuncan 08-25-2003 10:31 PM

Problems with Konqueror
 
Ok, I am running a Mandrake 9.1 system with KDE 3.1.

I opened the menu editor to edit the K menu and I noticed several entries for Konueror that didn't seem to be appearing in my menu, so I deleted the ones that appeared to be superflous...

The reason I did this is that I figured no one in their right mind would have portions of the GUI depend on what's listed in the menu... it appears that the KDE developers are not in their right mind.

No sooner had I deleted these entries than the "Home" button on the button bar and the "Home" icon on the desktop stopped working. Normally, these would open a Konqueror session on my home dir...

Additionally, I can no longer access items on the NewsTicker, I click on them and a task called "Lynx" appears briefly and then goes away. Why would it be tyring to open a text based browser???

This is really odd...

I checked out what the icon/button entries for "Home" were actually calling "under the hood" and it was:

kfmclient openProfile filemanagement

So I opened up a shell and typed it in, it then complained that I was missing "/usr/share/services/konqueror.desktop" which indeed did not exist.

So I did a search of the hard drive for "konqueror.desktop" and it turned up in the following places:

/usr/share/applnk/
/usr/share/applnk-mdk/
/home/joe/.kde/share/applnk-mdk/

But they're all different sizes!!! I figured that /usr/share/applnk-mdk/konqueror.desktop might be the closest to the missing /usr/share/services/konqueror.desktop but no dice, now I get:

kfmclient openProfile filemanagement
ERROR: Couldn't start konqueror from konqueror.desktop: Could not find service 'konqueror.desktop'.

I also get this when I run plain "konqueror" from the shell as root:

kio (KService*): WARNING: The desktop entry file konqueror.desktop has Type=Application but is located under "services" instead of "apps"
kio (KService*): WARNING: Invalid Service : konqueror.desktop

However, Konqueror then loads and runs fine as root...

What is going on and how do I fix it?

JoeDuncan 08-25-2003 10:33 PM

Forgot one more unrelated problem I am having with Konqueror, ever since I installed MDK 9.1, when I click on a file in Konquerer it says:

"<blahblah> is a file, but a directory was expected."

and does nothing...

Thanks!

simon_hacker 09-09-2003 12:36 PM

simple solution worked for me really; turn off "LinkView" in the menu under "view"

dont know if its works for you, but it should be that simple

JoeDuncan 09-10-2003 12:47 PM

I have managed to fix the problem by deleting my ".kde" folder (after backing it up of course)

After that I logged out and back in and the KDE settings (thus Konquerors as well) were recreated and all worked fine. I was then able to selectively restor my config settings from my backed up .kde folder...


All times are GMT -5. The time now is 03:35 AM.