Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-03-2003, 01:44 AM   #1
LQ Newbie
Registered: Oct 2003
Location: Santa Clara, California, US
Distribution: SuSE 9.0 Professional
Posts: 4

Rep: Reputation: 0
Problems with glib and gaim, with SuSE 8.2.

Alright, so I'm trying to update my installation of GAIM using gnome. I downloaded the tarball from gaim's sourceforge site, and tried to ./configure it. It came up with an error that I needed to update glib. So i did.

When it came to installaing glib, it told me that I needed pkgconfig, which I was able to install like a charm. As a result, I was able to install glib as well.

Of course, when I go back to gaim to attempt the ./configure command, it gives me the same error regarding having an incorrectly installed version of glib. This is baffling, because I've installed it several times without error messages.

I am using SuSE 8.2. I have not been able to install any RPM's, because there do not seem to be any out there and, to be honest, I don't know how they work on this OS. I'm a relative newbie -- I've been here for maybe a few months now.

Any help would be greatly appreciated.
Old 01-28-2004, 02:47 PM   #2
LQ Newbie
Registered: Aug 2003
Location: Shropshire, UK
Posts: 19

Rep: Reputation: 0
I have the same problem (suse 8.2, I'll use Debian in future), the error message caused by ./configure is:

*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at

Please help if you can!
Old 01-28-2004, 02:48 PM   #3
LQ Newbie
Registered: Aug 2003
Location: Shropshire, UK
Posts: 19

Rep: Reputation: 0
By the way, GLib 2 *is* already installed, so I installed the developer version, but it didn't make any difference.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling GAIM says i need GLib 2.0, yet i have GLib 2.4 MadSkillzMan Linux - Newbie 3 07-10-2004 05:10 AM
Problem with gaim/glib Oakstaff Linux - Software 5 04-21-2004 02:27 AM
Gaim .66 glib 2.0 error p1az Linux - Software 4 08-05-2003 12:32 PM
GAIM 0.62 and GLib kko88 Linux - Software 9 05-23-2003 04:33 PM
glib 2.0.0 and gaim 0.59 GT I.N.C Linux - Newbie 2 07-10-2002 01:10 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:25 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration