-   Linux - Software (
-   -   Problems with ./config and installing themes - Newbie going crazy! (

danksmith 12-02-2005 02:07 PM

Problems with ./config and installing themes - Newbie going crazy!
Hey everyone,

I am hoping someone can help me. I am new to Linux, running Mandrake10.1 and having a couple very frustrating problems:

1) The ./configure command.
Every time I am trying to open a tarball and install a file, I try to go through the ./configure, make, make install process, but I get this error message:

bash: ./configure: No such file or directory

here is the entire dialogue of a recent such problem:

[root@CPE00080d216e60-CM00111ae63ff4 acqua-3.2]# ./configure --prefix= kde-config --prefix
bash: ./configure: No such file or directory

It's as though my konsole thinks i am trying to open a directory when I thought ./configure was a command?

What is going on? So far the only program I have successfully installed is this one- Firefox, and I am not even really sure how I did that. I got Gaim to work finally, after an endless stream of dependencies... but now it is giving me an NSS error when I try to use MSN and I can't get NSS to work.....

2) I installed a Theme, called Acqua step by step by the instructions in the Readme, and it said in my console- Acqua-3.2 Installed... but I can find the folder, but I can't seem to find the app anywhere in my folder tree. More annoyingly, while I was able to add the Acqua background from the LooknFeel window, the theme is not showing up in either icons (IceWM is supposed to show up, so it says in the RM?) or under widget themes.
Am I doing something wrong? Is there some sort of configuration necessary after installation to get KDE to recognize the theme?

I really wanted to give Windows the boot and I thought Linux would be a good option, but the way Mandrake is cooperating, I am very nearly ready to toss my pc and go mac.

If anyone can help with any of these issues- especially the config one, that would be really appreciated.


bigrigdriver 12-02-2005 03:09 PM

The ./configure command.

When you unpack a tarball, it will usually create a folder named after the tarball. Configure is a script in that directory. You must do one of two things to run that script.

1) cd into the folder, and run ./configure. The ./ tells bash "in this directory". So, it you are in a different directory and try to run ./configure, the result you get depends on whether or not there is a configure script in that directory.

2) to run the configure script from anywhere in the system, give the /full/path/to/configure. Example: open a term window, and you are in your home directory. You have a tarball unpacked in /usr/local/<some app>. To run configure from home, give the command this way: /usr/local/<some app>/configure [options].

When you give the full path to an executable script, bash can find it. If you don't use the full path, then use ./ to tell bash "it's in this directory".

Note: not all tarballs will have a configure script. After unpacking a tarball, the first thing you should do, before anything else, is read two files from the tarball: README and INSTALL. Either one, or perhaps both, will have installation instructions.

danksmith 12-02-2005 04:19 PM

Hey bigrig- thanks for the help. That makes sense now- that I am basically asking it to execute a file called configure. I guess my problem now is that the README is saying to do the ./configure command, but there is no configure file in any of the folders from the unzipped tarball. How then can I install the acqua theme, or anything else for that matter?

bigrigdriver 12-02-2005 04:56 PM

If there is no configure file, then it's probably one of those infrequent tarballs that don't require one. Look for a file called INSTALL. Installation instructions are there. Or, to back to the website you downloaded from, and look for a Documentation link.

It could also be that, as a theme, it doesn't have to be compiled, just umpacked. Then follow the instructions

here . Scroll down to 'How to install themes".

All times are GMT -5. The time now is 07:38 AM.