LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-16-2004, 05:09 AM   #1
3spre10
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE
Posts: 21

Rep: Reputation: 15
Unhappy Problems using squirrel webmail...


Well recently i have completely reinstalled SuSE 9.1 because my hdd had a sudden death . Meanwhile i decided to install courier-imap and make a webmail for my users (not many - about 11).

Nothing wrong with the configuration and installing. The imap responds to a telnet on 143 dirtectly to my ip, so no problems so far.
The next step i took was to choose a webmail so squirrelmail was my choice. I downloaded the package, i planted it into my domain's folder and configuring it to function without ssl.
Well after setting all up - i just started a browser and paste the test link there : http://www.domain.com/squirrel-t01/ and look what i got :

Fatal error: Call to undefined function: session_id() in /path_to/www/domain/squirrel_t01/functions/global.php on line 293

I guess the problem comes from apache 2 (i'm using it) and it's cookie related or session related. Any ideea what went wrong? I have to mention that i'm using vhosts - so i have more than one domain and sub-domains on my webserver. Should i add something special in the conf regarding this domain between <VirtualHost> tags?

Thanks in advance.
 
Old 09-16-2004, 03:27 PM   #2
huibert.alblas
Member
 
Registered: Jan 2004
Location: Duesseldorf /Germany
Distribution: Gentoo amd64 / Debian
Posts: 226

Rep: Reputation: 30
PHP session_di

Just a quick guess,

what php version do you use,
what version does squirel mail like to have??
 
Old 09-17-2004, 08:25 AM   #3
3spre10
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE
Posts: 21

Original Poster
Rep: Reputation: 15
Im using PHP 4.3.4 with SquirrelMail 1.4.3a ... and still have that error

... and yes i have pop3 and smtp installed else i couldnt install-configure imap succesfully...

Last edited by 3spre10; 09-17-2004 at 08:27 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squirrel nkutty Linux - Security 1 11-18-2005 10:10 PM
Squirrel Mail Ornery_Boy Linux - Software 2 05-19-2005 09:50 AM
Squirrel mail problems Malkaven Linux - Networking 1 05-09-2005 09:34 AM
Squirrel Mail LeniuNYC Linux - Software 11 03-07-2004 12:47 PM
squirrel mail depaul Linux - Newbie 7 02-26-2004 12:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration