-   Linux - Software (
-   -   Problems using Grass 5.0.3 as user not root (

WESS126 04-16-2004 05:51 AM

Problems using Grass 5.0.3 as user not root
Dear Friends

I am running Mandrake 9.2 download Edition. I have recently installed grass 5.0.3. I did everything they said I should (there really isn't much to it) and it works fine.......................if I am logged in as root. Basically when I am logged in as a user (me) linux does not recognize the prompt "grass5", if I log in as su it all goes fine. This is workable, I just a little concerned about lurking around my system as root.
Can anyone who has some experience in using GRASS help me out?

Cheers Thanks Guys, looking forward to your replies.
:newbie: :cry: :D

ranger_nemo 04-16-2004 03:56 PM

You might have to add the directory containing grass to your path. Try running the program with the full path. I don't know what it is, so I'll give you a fake one... "/usr/grass/grass5". If you don't know where it is, you can use "locate grass5". If it works with the full path, you can add the directory containing the program to your path. It's in .bash_profile in your home directory.

If it gives you a permissions error when you try the full path, you might have to change the permissions of the program, or add yourself to the grass group.

Let me know if you get it working, and what you think of the program. I'm a forester and use ArcGIS at work, and have looked at GRASS a couple times, but haven't tried it yet.

WESS126 04-19-2004 03:20 AM

Thanks for the Reply.
I spent most of the weekend getting it working, I used full path names when I ran the install script and I think it did the trick (After about 20 reinstalls).

Have not really looked at any of the applications available in grass, still trying to fine tune the install. I am told that if and when you master the prog it is as powerfull as Workstation ArcInfo.....................and its free. Will let you know how it goes.

All times are GMT -5. The time now is 08:47 PM.