LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-20-2017, 04:38 PM   #1
Brant
Member
 
Registered: Oct 2007
Posts: 203

Rep: Reputation: 13
problems running or installing the Calibre e-reader


I am using Linux Mint 17.3. For some time I have had Calibre installed, principally for reformatting e-books, and use it on average once or twice a week.

Recently it failed to launch. Using the Software Manager I uninstalled and then reinstalled Calibre, without improvement.

I then visited the Calibre website and attempted to download the latest version (2.77) but download ended with the following message in the terminal:

Downloaded 61609836 bytes
Checking downloaded file integrity...
Extracting files to /opt/calibre ...
Extracting application files...
WARNING: Failed to set default libc locale, using en_US.UTF-8
Traceback (most recent call last):
File "site.py", line 64, in main
File "site-packages/calibre/__init__.py", line 22, in <module>
File "site-packages/calibre/startup.py", line 105, in <module>
File "locale.py", line 543, in getdefaultlocale
File "locale.py", line 475, in _parse_localename
ValueError: unknown locale: 1q2w3e
/opt/calibre/lib/python2.7/site-packages/calibre/ptempfile.py:29: RuntimeWarning: Parent module 'calibre' not found while handling absolute import
Run "calibre" to start calibre

This did not leave me much the wiser. . .but in any case, Calibre was not present in the menu.

Are there any ideas why the version available through Software Manager suddenly refuses to run, or how to successfully install the later version from the Calibre website?
I considered upgrading to Mint 18.1, but was curious if there were other answers.
 
Old 01-20-2017, 05:20 PM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.1 MATE
Posts: 8,018
Blog Entries: 5

Rep: Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869
Can you please post here the output from the locale command.
 
Old 01-20-2017, 08:40 PM   #3
Brant
Member
 
Registered: Oct 2007
Posts: 203

Original Poster
Rep: Reputation: 13
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
 
Old 01-21-2017, 01:32 AM   #4
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.1 MATE
Posts: 8,018
Blog Entries: 5

Rep: Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869
Ok. Looks like a corrupted locale. Which country are you in and which language is your computer normally set up to use?
 
Old 01-22-2017, 01:45 PM   #5
Brant
Member
 
Registered: Oct 2007
Posts: 203

Original Poster
Rep: Reputation: 13
Canada. English.
 
Old 01-23-2017, 03:33 AM   #6
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.1 MATE
Posts: 8,018
Blog Entries: 5

Rep: Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869Reputation: 2869
Ok. I'm assuming that you're using the Cinnamon desktop. If that's not the case then let me know or find the equivalent operation in your desktop environment's system settings control panel.

So, for Cinnamon: System Settings->Preferences->Languages.

Change both Language and Region to English, Canada UTF-8

Then click on the Apply System-Wide button.

You may well then need to log out and log back in again to effect the changes. Running the locale command will confirm whether your computer is now set to the new locale.
 
1 members found this post helpful.
Old 01-23-2017, 08:01 PM   #7
Brant
Member
 
Registered: Oct 2007
Posts: 203

Original Poster
Rep: Reputation: 13
And success!
Thank you very much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Calibre 1.37 eBook Reader and Editor Now Features Much Better Spell Checking LXer Syndicated Linux News 0 05-16-2014 11:21 PM
LXer: eBook Reader and Editing Software Calibre Gets Even Better with New Release LXer Syndicated Linux News 0 03-21-2014 04:43 PM
LXer: Calibre 1.20 Is the Ultimate eBook Reader and Editor LXer Syndicated Linux News 0 01-17-2014 01:40 PM
LXer: eBook Reader and Editing Software Calibre 1.18 Is Almost Perfect LXer Syndicated Linux News 0 01-04-2014 04:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration