-   Linux - Software (
-   -   Problems running make install for php (

jimieee 12-24-2003 10:51 AM

Relocation error GLIBC, pear installer error 127
Hi I'm trying to install apache with php on my Redhat 9 box from source (I need to run apache 1.3, rather than 2). I have apache and mod_ssl running ok, so I moved onto getting php up and running. I made a little script to configure php, which goes as follows:

CC="gcc" \
LDFLAGS="-lstdc++" \
CPPFLAGS="-I/usr/kerberos/include" \
"./configure" \
"--with-apxs=/usr/local/apache/bin/apxs" \
"--with-mysql=/usr/" \
"--with-openssl=/usr/" \
"--with-imap=/usr/" \
"--with-gd=/usr/" \
"--with-ldap=/usr/" \
"--enable-ftp" \
"--with-kerberos" \
"--enable-sysvsem" \
"--enable-sysvshm" \
"--enable-sockets" \

which seems to work fine and the make runs without hitch, but when I go to make install:

Installing PHP CLI binary: /usr/local/bin/
[various positive looking output]
Installing PEAR environment: /usr/local/lib/php/
/usr/src/apache/php-4.3.4/sapi/cli/php: relocation error: /usr//lib/libmysqlclie symbol errno, version GLIBC_2.0 not defined in file with lin
k time reference
make[1]: *** [install-pear-installer] Error 127
make: *** [install-pear] Error 2

I've googled around, tried lots of fixes recommended by people, even though they were all installing different software. I still don't have a fix though, or a clue the problem is!! Can anybody make any recommendations? Please Please Please help, it is Christmas after all!

Merry Christmas!



trickykid 12-24-2003 11:46 AM

Did you su to root?

$ ./configure
$ make
$ su -m <-m flag will log you in as root and stay in pwd>
# make install
# exit

jimieee 12-24-2003 12:52 PM

hhmmmm thanks for the advice, tried it but same error. Am I passing bad config commands or something?



trickykid 12-24-2003 12:58 PM

Does it error when not using your script?

jimieee 12-24-2003 07:09 PM

Well without the flags it won't, because Redhat has issues with Kerberos. But when I include just the flags I get a different error - this time during the make command:

gcc: sapi/cli/php_cli.o: No such file or directory
gcc: sapi/cli/getopt.o: No such file or directory
make: *** [sapi/cli/php] Error 1

The simplest version of ./configure I can make is with the

"--with-apxs=/usr/local/apache/bin/apxs" \
"--with-mysql=/usr/" \

lines, then it goes back to the same pear error. hmmmm I suppose there isn't anything wrong with my configuration script huh? Now I'm even more confused! :)

Thanks for this by the way :)



jimieee 12-30-2003 03:37 AM

I've been looking around some more and trying new things, I think this is something to do with dependencies in shared libraries. Now I don't know for sure, but I don't think this looks right, I'll put in bold the lines that worry me:

# ldd /usr/src/apache/php-4.3.4/sapi/cli/php => /lib/ (0x40028000) => /usr//lib/ (0x40055000) => /lib/ (0x40086000) => /lib/tls/ (0x40098000) => /lib/ (0x400ba000) => /lib/ (0x400be000) => /lib/tls/ (0x42000000) => /usr//lib/ (0x400d4000) => /lib/ (0x400e2000) => /lib/ (0x400ee000)
/lib/ => /lib/ (0x40000000)

as you can see, the files that they depend on have // it the path, which is unusual right? Could this be causing the problem? If so, how would I go about fixing it? Any help much appreciated!!



p.s. I should also add that I've got php to "make install" now, but I have to add "--without-pear" to my configuration script. However, when I try to start apache:

# /usr/local/apache/bin/apachectl start
Syntax error on line 208 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/ into server: /usr//lib/ symbol errno, version GLIBC_2.0 not defined in file with link time reference
/usr/local/apache/bin/apachectl start: httpd could not be started

ARGH!! Same error!

All times are GMT -5. The time now is 10:10 PM.