LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problems running compiled mozilla (https://www.linuxquestions.org/questions/linux-software-2/problems-running-compiled-mozilla-93024/)

preacher34 09-15-2003 10:35 AM

Problems running compiled mozilla
 
Hello all, I need some help.

I tried compiling and installing mozilla-1.5b, the same way I successfully compiled and installed 1.4, but mozilla wouldn't start afterwards, the window came up for a second then immediately shuts down, without giving any error message, neither in console nor otherwise.

A bit discouraged I decided to continue with 1.4 for a while, and compiled and installed it, but alas, the same error occurs!

The mozilla window comes up, then immediately exits without giving a hint to what's wrong.

These are the build options I'm using:

./configure --prefix=/usr
--enable-default-mozilla-five-home
--enable-toolkit-gtk2
--enable-default-toolkit=gtk2
--with-x
--with-system-zlib
--with-system-jpeg
--with-system-png
--with-system-mng
--enable-xft
--enable-crypto
--enable-java-supplement
--disable-accessibility
--disable-tests --disable-debug
--disable-logging --enable-reorder
--enable-strip
--enable-cpp-rtti
--enable-extensions="default,-venkman,-inspector,-irc"
--enable-svg
--enable-elf-dynstr-gc
--disable-mailnews
--disable-ldap
--enable-plaintext-editor-only

These are the same build options I've used to compile mozilla-1.4 successfully before, and I'm using the exakt same optimizations as well.

A bit frustrated I decided to change the --disable-debug above to --enable-debug, otherwise using the same options.

Now mozilla starts and is working fine (albeit a bit slow since it prints tons of debug-messages).

But why will it work with debug enabled, but not at all otherwise?

Not a permissions problems since it's the same for root as it is for users. I also tried deleting my mozilla profile but still no go.

Please help, what could the problem be?

(Of course I'm running the standard "./regxpcom && ./regchrome" etc etc after compiling and installing)


All times are GMT -5. The time now is 08:36 PM.