LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problems Removing rpm packages (https://www.linuxquestions.org/questions/linux-software-2/problems-removing-rpm-packages-766438/)

Isuru Divarathne 11-03-2009 04:43 AM

Problems Removing rpm packages
 
[root@localhost ~]# rpm -qa | grep pcap
libpcap-0.8.3-10.RHEL4

[root@localhost ~]# rpm -e libpcap-0.8.3-10.RHEL4

error: Failed dependencies:
libpcap.so.0.8.3 is needed by (installed) ppp-2.4.2-6.4.RHEL4.i386

libpcap >= 14:0.8.3-6 is needed by (installed) ppp-2.4.2-6.4.RHEL4.i386

but above versions are <= than prevailing i can't install them.. :(

watcher69b 11-03-2009 05:42 AM

You will 1st need to remove what relys on it.

rpm -e ppp-2.4.2-6.4.RHEL4.i386

rpm -e libpcap-0.8.3-10.RHEL4

Isuru Divarathne 11-04-2009 12:12 AM

THANKS VERY MUCH FOR YOUR HELP watcher69b
i successfully uninstalled all failed dependecies
and i got removed the current libpcap
but..
when i try to install following libpcap i gt following error
problem is
libc.so.6(GLIBC_2.4) and rtld(GNU_HASH) gives errors again...


[root@localhost usr]# rpm -Uvh libpcap-0.9.4-14.el5.i386.rpm
warning: libpcap-0.9.4-14.el5.i386.rpm: V3 DSA signature: NOKEY, key ID e8562897error: Failed dependencies:
libc.so.6(GLIBC_2.4) is needed by libpcap-0.9.4-14.el5.i386
rtld(GNU_HASH) is needed by libpcap-0.9.4-14.el5.i386

John VV 11-04-2009 02:03 AM

you DO KNOW that "libpcap-0.9.4-14.el5.i386.rpm" is for red hat 5 and not rhel4
it is incompatible with rhel 4

forcing the install of a rhel 5 rpm on rhel 4 OS is NOT a good idea


All times are GMT -5. The time now is 07:59 AM.